Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

1721 with WIC-2AM analog modem callback

I try to configure callback with 1721 and Radius ACS3.3.

The configuration is the following:

Building configuration...

Current configuration : 2413 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname RASCDT

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$lAIe$6eZmk3f/EAX17iNLhbquO/

!

aaa new-model

!

!

aaa authentication login default group radius local

aaa authentication ppp default if-needed group radius

aaa authorization network default group radius

aaa accounting exec default start-stop group radius

aaa accounting network default start-stop group radius

!

aaa session-id common

!

resource policy

!

ip subnet-zero

!

!

no ip dhcp use vrf connected

!

!

ip cef

no ip domain lookup

ip domain name cam

async-bootp dns-server xxxxxxxxxxxx

async-bootp nbns-server xxxxxxxxxxxxx

!

chat-script CALLBACK ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 30 CONN

ECT \c

chat-script offhook "" "ATH1" OK \c

username administrator password 7 xxxxxxxxxxxxxxx

!

!

!

interface FastEthernet0

ip address 192.168.XXX.XX 255.255.255.0

speed auto

!

interface Async1

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression

dialer in-band

async mode interactive

peer default ip address pool default

ppp callback accept

ppp authentication chap

!

interface Async2

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression

dialer in-band

async mode interactive

peer default ip address pool default

ppp authentication chap

!

interface Async3

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression

dialer in-band

async mode interactive

peer default ip address pool default

ppp callback accept

ppp authentication chap

!

interface Async4

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression

dialer in-band

async mode interactive

peer default ip address pool default

ppp authentication chap

!

ip local pool default yyyyyyyyyyyy yyyyyyyyyyyy

ip classless

ip route 0.0.0.0 0.0.0.0 xxxxxxxxx

no ip http server

!

!

dialer-list 1 protocol ip permit

radius-server host xxxxxxxxxx auth-port 1645 acct-port 1646

radius-server timeout 30

radius-server key 7 03165A18070C321D1C

!

control-plane

!

!

line con 0

line 1 4

script modem-off-hook offhook

script callback CALLBACK

modem InOut

transport input all

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

end

When i try to callback the client receive popup for callback number but callback don't start.

On ACS3.3 i set attibute 006 (framed) and 007 (ppp) .

have you any suggestions ??

thanks

3 REPLIES
VIP Purple

Re: 1721 with WIC-2AM analog modem callback

Hello,

try to configure line 1 4 as following:

script connection offhook

script dialer callback

Also, add 'ppp callback accept' to the configuration of Async2 and Async 4.

Can you post the output of 'debug modem' when your client dials in ?

Regards,

GP

New Member

Re: 1721 with WIC-2AM analog modem callback

I change configuartion with script connection offhook

and script dialer callback but i have the problem it's the same.The debug output is:

RASCDT#deb modem

Modem control/process activation debugging is on

RASCDT#

RASCDT#

RASCDT#

RASCDT#

RASCDT#

*Mar 9 19:38:00.237: Modem (0/2) DCD Asserted

*Mar 9 19:38:00.525: TTY3: DSR came up

*Mar 9 19:38:00.525: Modem 0/2 WIC-AM: in modem state 'Connect'

dte = modulation= Unkn protocol = compression_type = NONE tx_speed = rx_spee

d =

*Mar 9 19:38:01.525: tty3: Modem: IDLE->(unknown)

*Mar 9 19:38:01.533: TTY3: Autoselect started

*Mar 9 19:38:01.533: TTY3: create timer type 0, 120 seconds

*Mar 9 19:38:02.389: TTY3: Autoselect sample 7E

*Mar 9 19:38:02.393: TTY3: Autoselect sample 7EFF

*Mar 9 19:38:02.393: TTY3: Autoselect sample 7EFF7D

*Mar 9 19:38:02.393: TTY3: Autoselect sample 7EFF7D23

*Mar 9 19:38:02.393: TTY3 Autoselect cmd: ppp negotiate

*Mar 9 19:38:02.397: TTY3: destroy timer type 0

*Mar 9 19:38:02.397: TTY3: EXEC creation

*Mar 9 19:38:02.401: TTY3: create timer type 1, 600 seconds

*Mar 9 19:38:02.405: TTY3: destroy timer type 1

*Mar 9 19:38:02.405: TTY3: no timer type 0 to destroy

*Mar 9 19:38:02.405: TTY3: no timer type 2 to destroy

*Mar 9 19:38:02.409: Modem 0/2 WIC-AM: switching to PPP mode

*Mar 9 19:38:02.417: Modem 0/2: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

*Mar 9 19:38:02.421: %LINK-3-UPDOWN: Interface Async3, changed state to up

*Mar 9 19:38:02.556: Modem 0/2: PPP escape map: Tx map = 0, Rx map = 0

*Mar 9 19:38:04.948: Modem (0/2) DCD UnAsserted

*Mar 9 19:38:05.556: TTY3: DSR was dropped

*Mar 9 19:38:05.556: tty3: Modem: READY->(unknown)

*Mar 9 19:38:06.556: TTY3: dropping DTR, hanging up

*Mar 9 19:38:06.556: TTY3: Async Int reset: Dropping DTR

*Mar 9 19:38:06.556: tty3: Modem: HANGUP->(unknown)

*Mar 9 19:38:06.556: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:07.560: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:07.560: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:08.332: Modem 0/2: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

*Mar 9 19:38:08.556: %LINK-5-CHANGED: Interface Async3, changed state to reset

*Mar 9 19:38:08.564: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:08.564: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:09.568: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:09.568: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:10.572: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:10.572: TTY3: cleanup pending. Delaying DTR

*Mar 9 19:38:11.556: Modem 0/2 WIC-AM: switching to character mode

*Mar 9 19:38:11.560: TTY3: no timer type 0 to destroy

*Mar 9 19:38:11.560: TTY3: no timer type 1 to destroy

*Mar 9 19:38:11.560: TTY3: no timer type 3 to destroy

*Mar 9 19:38:11.560: TTY3: no timer type 4 to destroy

*Mar 9 19:38:11.560: TTY3: no timer type 10 to destroy

*Mar 9 19:38:11.560: TTY3: no timer type 2 to destroy

*Mar 9 19:38:11.560: Async3: allowing modem_process to continue hangup

*Mar 9 19:38:11.576: TTY3: restoring DTR

*Mar 9 19:38:11.596: TTY3: Modem get info started

*Mar 9 19:38:12.104: TTY3: Modem: ATS86? -> 012OK

*Mar 9 19:38:12.704: TTY3: Modem: ATZ -> OK

*Mar 9 19:38:13.220: TTY3: Modem: AT&F\V1S0=1 -> OK

*Mar 9 19:38:13.564: %LINK-3-UPDOWN: Interface Async3, changed state to down

*Mar 9 19:38:23.556: Modem Registers - IMR:0x0 LED:0x0 RstCntrl:0x0 MSR:0xFF

*Mar 9 19:38:23.556: CHAT3: Attempting async line dialer script

*Mar 9 19:38:23.556: Modem Registers - IMR:0x0 LED:0x0 RstCntrl:0x0 MSR:0xFF

*Mar 9 19:38:23.560: CHAT3: process started

*Mar 9 19:38:23.560: CHAT3: Asserting DTR

New Member

Re: 1721 with WIC-2AM analog modem callback

i fix the problem with :

script dialer callback

and script with ATX3 :

chat-script callback ABORT ERROR ABORT BUSY "" "AT" OK "ATX3" OK "ATDT \T" TIMEOUT 30 CONN

358
Views
0
Helpful
3
Replies
CreatePlease to create content