Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2 Dialer Profiles for 1 ATM Interface (836)

Hi,

I'm managing many Homeoffices connected wit h a 836 without any problems. My local provider sometimes has problems with their realms in userid's, so I thought I could create a second dialer interface configured with a different (e.g. call by call) account.

But everytime I do this, the 836 only connects to the last dialer interface. When I set it to shut it never dials the first one. Also changing the accounts from 0 to 1 lets me only dial the second dialer. I've tested it on 12.3T and 12.4T. With, and without CEF and most dialer-watch examples, Everything doensn't work.

Here's a sample config:

interface ATM0

bandwidth 160

no ip address

no atm ilmi-keepalive

atm ilmi-pvc-discovery

dsl operating-mode annexb-ur2

pvc 1/32

pppoe-client dial-pool-number 1

!

!

[...]

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1300

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username XXX@XXX.de password xxxx

ppp ipcp dns request

ppp ipcp wins request

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1300

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username ZZZ@ZZZ.de password xxxx

ppp ipcp dns request

ppp ipcp wins request

!

[...]

dialer-list 1 protocol ip permit

Is there something I forgot? Thanks

Mase

  • Remote Access
6 REPLIES

Re: 2 Dialer Profiles for 1 ATM Interface (836)

It would be nice to know how you arranged ip routing for this setup. The router chooses the outgoing interface primarily based on the routing table.

if you had something like: ip route 0.0.0.0 0.0.0.0 interface dialer 1, I would consider it logical for the router to behave as described.

Regards,

Leo

New Member

Re: 2 Dialer Profiles for 1 ATM Interface (836)

Hi Leo,

thanks for you answer! I've set 0.0.0.0 to dialer 1 with metric 10 and 0.0.0.0 to dialer 0 with metric 20. My thought was that Cisco will router to dialer 0 automatically when dialer 1 changed to down. Disabling the metric will result in a packetloss of 50% because the Cisco wants to send the packets over both lines.

Is there another way to solve the routing issue?

Thanks!

Re: 2 Dialer Profiles for 1 ATM Interface (836)

The dialer is software-constructed interface that is always in a state of up-spoofed. The router simply used the route with the best metric.

I am afraid that the issue cannot be solved using static routes as they will never be able to reflect the actual availability of the ISP.

You should make the switch-over by hand.

Regards,

Leo

New Member

Re: 2 Dialer Profiles for 1 ATM Interface (836)

Isn't there another way, like replacing Dialer If's with VirtualTemplates? So I also can't use dialer-watch with 2 Dialer If's?

Thanks,

Mase

Re: 2 Dialer Profiles for 1 ATM Interface (836)

I am afraid there will be little other options.

You probably shouldn't bother too much as all existing connections will die anyway when there is a switchover to another dialer. This is because the existing nat translations will be invalid on the other dialer. This also implies that you will be reconnecting using a different IP which is equivalent to a new session when seen from the connected Internethost.

Regards,

Leo

New Member

Re: 2 Dialer Profiles for 1 ATM Interface (836)

I don't want to use it for 24h disconnects. My first DialUp provider sometimes has problems with his infrastructure and the connections is down for about half an hour. So I want to keep the downtime as short as possible and connect to another one. It's ok if the clients lose their connections for a short time, but I can't dial in (over ISDN) to all customers and activate the second dialer connection.

Thanks,

Mase

332
Views
0
Helpful
6
Replies