Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2509 terminal server wont connect

I have configure a 2509 as a terminal server so I can reverse telnet to my routers - I have the basic config setup as below..

Terminal-Server#sho run

Building configuration...

Current configuration : 697 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Terminal-Server

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

ip subnet-zero

ip host R1 2001 1.1.1.1

ip host R2 2002 1.1.1.1

ip host S1 2003 1.1.1.1

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Ethernet0

ip address 10.0.0.2 255.0.0.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

no ip http server

ip classless

!

!

!

!

line con 0

line 1 8

transport input all

exec-timeout 0 0

no exec

line aux 0

line vty 0 4

password terminal

login

!

!

end

However when I type R1 on the router the connection says its open but I do not get the router prompt below.?

I have tried this on a number of devices and nothing works.

Do I have to do anything on the remote devices?

How can I troubleshoot a dodgey octal cable?

Is my config wrong?

What debug command are available ?

Thanks - this has driven me mad all day...

Roger

5 REPLIES

Re: 2509 terminal server wont connect

Roger,

The configuration looks good on the terminal server. Can you access R1's console port directly from your PC using a console(rollover) cable? Make sure the console port on R1 isn't configured with the command 'no exec'. It could be a bad octal cable as well and I'm not sure how you troubleshoot that other than swapping it for a known working cable.

Have a look at this troubleshooting link.

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml

HTH

Sundar

Community Member

Re: 2509 terminal server wont connect

Yes I can access R1's console direct with the console cable from my PC.

No settings on console port on R1

line con 0

line aux 0

line vty 0 4

thanks for the sense check on the config - I am suspecting it is the cable but it looks fine - I am just trying to get hold of another one just to eliminate that.

Its just frustrating it looks like its working - when I telnet I get..

Terminal-Server#telnet 1.1.1.1 2001

Trying 1.1.1.1, 2001 ... Open

Then it just sits there..

Roger

Community Member

Re: 2509 terminal server wont connect

Hi simplecisco,

I am having the same problem, just wondering if you figure it out what was the reason for the issue eventually ?

thanks

Ling

Community Member

Re: 2509 terminal server wont connect

After hours of heartache and replacing the cable and trying every config I can think of decided it was a dodgey driver on the Port - ditched that router and got myself another 2509 and it works a treat.

One thing to check when you have the cable plugged into the 2509 does the green light come on - as on my box it didn't

Roger

Community Member

Re: 2509 terminal server wont connect

thanks Roger, I have find the issue as well,

I erase all the config on the router and connected the same octopus cable to another slot of the Asynch module, it works now.

one thing I noticed is the green light on the back of it somehow has no relation to if the port is working or not. when I first connected, I can see the green light, then it went off, but reverse telnet still works. if I wiggle the cable, the LED lights up from time to time ( I presume its connectivity issue, but that pin (which send signal to LED) has nothing to do the functionality of the reverse telnet. (I don't like the design of the Asyn socket, hard to push it in !!)

thanks again & B. regards,

Ling

201
Views
0
Helpful
5
Replies
CreatePlease to create content