Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2511 Terminal Server Question

Hi all,

Don't have too much experience setting up a 2511 term server. When I try to connect to a device from my terminal server, I am getting prompted for username/password. The banner for my term server also comes up. When I put in my username/password (there are no credentials on the remote devices), it hangs after the password goes in. I clear the line, but it happens again. Here is my config...what am I missing?

Current configuration : 1411 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname TermServ
!
aaa new-model
aaa authentication login default local
aaa authorization exec default local
enable secret 5 XXXX
!
username XXXX privilege 15 password 7 XXXXX
!
!
!
!
ip subnet-zero
ip host R5 2005 1.1.1.1
ip host R4 2004 1.1.1.1
ip host R3 2003 1.1.1.1
ip host R2 2002 1.1.1.1
ip host R1 2001 1.1.1.1
ip host R6 2006 1.1.1.1
ip host SW1 2007 1.1.1.1
ip host SW2 2008 1.1.1.1
ip host SW3 2009 1.1.1.1
ip host SW4 2010 1.1.1.1
ip host FRS 2011 1.1.1.1
ip host BB1 2012 1.1.1.1
ip host BB2 2013 1.1.1.1
ip host BB3 2014 1.1.1.1
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
ip address 192.168.0.30 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
banner motd ^CC
**************************************************************************

              Access to this device is strictly prohibited.

**************************************************************************^C
!
line con 0
password 7 XXXX
line 1 16
session-timeout 60
transport input telnet
line aux 0
line vty 0 4
exec-timeout 5 0
logout-warning 60
transport input telnet
!
end

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Thanks for posting the current version of the configuration. I agree that sometimes it is helpful to trim back and only put in the basics. It looks to me like this configuration should work. If you say that it still does not work then I would make these observations and suggestions:

- one common issue is that the octal cable is not plugged in where you think it is. The result is that cable 1 of the set which you think is on 2001 might actually be on 2009. (in fact that happened to me two weeks ago, so experience is not necessarily preventive of this error). So I suggest that you also configure another host on 2009 and try that.

- I would suggest that you unplug and re-plug the octal cable from the terminal server being sure that it is well seated in its connection. And it would be good to re-do the connection on the remote router as well.

- ocassionally there may be a problem with individual cables within the octal cable. So it might be good to configure and test with some cable other than 1.

- a previous post says that you can access the console successfully if you do not use the term server and just connect directly. I suggest that you try that again and make sure that nothing has changed while you have been working on it.

HTH

Rick

15 REPLIES
Hall of Fame Super Gold

2511 Terminal Server Question

Maybe the connected device is not working, or the cabling wrong.. etc.

New Member

2511 Terminal Server Question

Cabling has been checked and rechecked. The connected devices I can get to by consoling in normally. I redid the config on the terminal server and only put the basic stuff on, and still get the same.

New Member

2511 Terminal Server Question

It's funny that I get the same response to a connected device that is turned on and turned off. It's like I am bouncing the telnet session back to the 2511.

Hall of Fame Super Silver

2511 Terminal Server Question

Perhaps you are bouncing it back to the 2511. Put this into your config

line 1 16

no exec

Give this a try and let us know if it works better.

HTH

Rick

Hall of Fame Super Gold

2511 Terminal Server Question

Oh, that's right, I missed that.

New Member

Re: 2511 Terminal Server Question

Still nothing. What iOS should I be on?

Sent from Cisco Technical Support iPhone App

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

It is very unlikely that there is any problem with the version of IOS that you are on (and the choices for a 2511 are extremely limited. It is much more likely to be some issue in the configuration or in the operation/cabling/etc.

A good next step would be for you to post the current version of the running configuration.

HTH

Rick

New Member

Re: 2511 Terminal Server Question

I basically re-did it, and put only the basics on.

Current configuration:

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Router

!

enable secret 5 xxxxxxx

!

username xxxxx privilege 15 password 7 xxxxxx

ip host R1 2001 1.1.1.1

!

!

interface Loopback1

ip address 1.1.1.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Ethernet0

ip address 192.168.0.30 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Serial0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

!

!

line con 0

line 1 16

no exec

transport input telnet

line aux 0

transport input all

line vty 0 4

password xxxx

login

!

end

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Thanks for posting the current version of the configuration. I agree that sometimes it is helpful to trim back and only put in the basics. It looks to me like this configuration should work. If you say that it still does not work then I would make these observations and suggestions:

- one common issue is that the octal cable is not plugged in where you think it is. The result is that cable 1 of the set which you think is on 2001 might actually be on 2009. (in fact that happened to me two weeks ago, so experience is not necessarily preventive of this error). So I suggest that you also configure another host on 2009 and try that.

- I would suggest that you unplug and re-plug the octal cable from the terminal server being sure that it is well seated in its connection. And it would be good to re-do the connection on the remote router as well.

- ocassionally there may be a problem with individual cables within the octal cable. So it might be good to configure and test with some cable other than 1.

- a previous post says that you can access the console successfully if you do not use the term server and just connect directly. I suggest that you try that again and make sure that nothing has changed while you have been working on it.

HTH

Rick

New Member

Re: 2511 Terminal Server Question

Thanks for all your help. I ordered two new octal cables and it worked. Both cables I had were bad. Thanks again!!

Sent from Cisco Technical Support iPhone App

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

I am glad that you got it worked and that that it is now working ok. Thank you for posting back to the forum and indicating that you had solved the problem. And thank you for using the rating system to indicate that your question was answered. It makes the forum more useful when people can read a question and can know that a solution was found. Your marking has contributed to this process. And it is good to point out that sometimes our problems are not necessarily the result of configuration problems. Sometimes we need to also look for physical problems (like bad cables).

HTH

Rick

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Hello Rick,

as usual you provide the solution to this kind of issue.

 

I just want to add that for a C2921 using Zone based Firewall the loopback to be used for reverse telnet has to be associatiated to the same zone as the zone where the user PC is connected to.

Also I have found out that in a setup  R1:aux0 to ASA:con0 the cable has to be straight.

 

Bests Regards

Giuseppe Larosa

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Giuseppe

 

Thank you for the kind words. Your observations about zone based firewall are helpful and deserve+5

 

HTH

 

Rick

Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Hello Rick,
just an update the correct cable setup requires null-modem, all other notes I wrote are correct.
Best Regards
Giuseppe Larosa
Hall of Fame Super Silver

Re: 2511 Terminal Server Question

Hello Rick,

thanks for your kind remarking you are a gentleman and you have been my reference when I started to write on netpro now Cisco Supporting Forums.

thanks I want to post my tests in an Excel File showing my findings.

 

I'm stucked as I am not able to arrange a null modem cable setup, however I think that the logs I have collected on the excel spreadsheet demonstrate that configuration is correct.

Note:

before adding loop100 to security zone NOC reverse telnet to TCP port 2001 failed with connection refused..

 

Best Regards

Giuseppe Larosa

 

2151
Views
20
Helpful
15
Replies
CreatePlease login to create content