Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2900 router for dialup remote access

I need to configure a 2921 router with a 1 port and a 2 port  T1/E1-PRI EHWIC to replace an old AS5350XM RAS server. Trying to locate documentation for such a config is frustrating to say the least.

I took my best shot at configuring this thing, and it will answer calls, but the console just shows that an incoming ISDN call (with an associated serial interface) was answered, and then after 60 seconds, it shows a disconnect. I had debugs running for ppp authentication and radius authentication but there was no activity at all from those.

The relevant bits of the config follow. What's missing and/or messed up here? The router claims to have 36 "modems" available. Dial up configuration seems to be well on its way to becoming a lost art!

CONFIG:

version 15.1

!

hostname RasX

!

card type t1 0 0

card type t1 0 1

!

aaa new-model

!

aaa authentication login default group radius local

aaa authentication login NO_AUTHEN none

aaa authentication login SSH group tacacs+ local

aaa authentication ppp default group radius local

aaa authorization exec default group tacacs+ local

aaa authorization network default group radius local

aaa accounting delay-start

aaa accounting session-duration ntp-adjusted

aaa accounting exec default start-stop group tacacs+

aaa accounting exec remoteacc start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting commands 15 cmdacc stop-only group tacacs+

aaa accounting network default start-stop group radius

aaa accounting connection default start-stop group tacacs+

aaa accounting system default start-stop group tacacs+

!

aaa session-id common

no network-clock-participate wic 0

no network-clock-participate wic 1

!

ip cef

!

no ip dhcp use vrf connected

!

multilink bundle-name authenticated

!

isdn switch-type primary-ni

!

voice-card 0

!

redundancy

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24

!

controller T1 0/1/0

cablelength long 0db

pri-group timeslots 1-24

!

controller T1 0/1/1

cablelength long 0db

pri-group timeslots 1-24

!

!

interface Loopback1

ip address 192.168.X.254 255.255.255.0

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description da_ethernet_one

ip address 10.X.X.225 255.255.255.0

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly in

ip verify unicast reverse-path

duplex auto

speed auto

!

interface Serial0/0/0:23

ip unnumbered GigabitEthernet0/0

encapsulation ppp

dialer-group 1

peer default ip address pool setup_pool

isdn switch-type primary-ni

isdn incoming-voice modem

keepalive 10 3

ppp authentication pap

ppp multilink

no cdp enable

!

interface Serial0/1/0:23

ip unnumbered GigabitEthernet0/0

encapsulation ppp

dialer-group 1

peer default ip address pool setup_pool

isdn switch-type primary-ni

isdn incoming-voice modem

keepalive 10 3

ppp authentication pap

ppp multilink

no cdp enable

!

interface Serial0/1/1:23

ip unnumbered Loopback1

encapsulation ppp

dialer-group 1

peer default ip address pool setup_pool

isdn switch-type primary-ni

isdn incoming-voice modem

keepalive 10 3

ppp authentication pap

ppp multilink

no cdp enable

!

interface Group-Async0

physical-layer async

no ip address

encapsulation slip

no group-range

!

interface Group-Async1

ip unnumbered Loopback1

ip flow ingress

encapsulation ppp

ip tcp header-compression

peer default ip address pool setup_pool

async mode interactive

no keepalive

ppp authentication pap

group-range 0/195 0/230

!

!

dialer-list 1 protocol ip permit

!

no cdp run

!

tacacs server XXX

address ipv4 10.X.X.1

key 7 ###########################

!

radius server XXX

address ipv4 10.X.X.1 auth-port 1645 acct-port 1646

key 7 ###########################

!

!

mgcp profile default

!

!

gatekeeper

shutdown

!

!

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 0/195 0/230

no flush-at-activation

modem Dialin

autoselect during-login

autoselect ppp

!

scheduler allocate 20000 1000

end

2 REPLIES
Hall of Fame Super Gold

2900 router for dialup remote access

can you begin sending "show inventory" ?

New Member

2900 router for dialup remote access

Solved:

The WICs needed some clock settings:

network-clock-participate wic 0

network-clock-participate wic 1

network-clock-select 1 T1 0/1/0

network-clock-select 2 T1 0/0/0

network-clock-select 3 T1 0/1/1

1227
Views
0
Helpful
2
Replies
CreatePlease login to create content