Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

4G EHWICS Finally arrived! Now how to configure...

Hey All,

My long-awaited 4G EHWICs have arrived for my ISRG2 routers. We've gotten SIM cards from Verizon Wireless that have been activated and now i'm trying to make the card work.

I've followed the instructions at this link:

www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/EHWIC-4G-LTESW.html

to do a very basic config, but my interface is still not working correclty.

IOS: 15.1(4)M4

Platform: 2911 SRST/K9

Question 1: Anyone know why my interface shows up as four interfaces on one EHWIC?

yourname#sh ip int brief

Interface                  IP-Address      OK? Method Status                Prol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down dow

GigabitEthernet0/0         10.10.10.1      YES NVRAM  down                  dow

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down dow

GigabitEthernet0/2         unassigned      YES NVRAM  administratively down dow

Cellular0/0/0              unassigned      YES NVRAM  up                    up

Cellular0/0/1              unassigned      YES unset  down                  dow

Cellular0/0/2              unassigned      YES unset  down                  dow

Cellular0/0/3              unassigned      YES unset  down                  dow

Loopback0                  192.168.1.100   YES NVRAM  up                    up

NVI0                       192.168.1.100   YES unset  up                    up

yourname#

Question 2: What am I missing?

chat-script lte"" "AT!CALL1" TIMEOUT 60 "OK"

!

interface Loopback0

ip address 192.168.1.100 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer string lte

dialer-group 1

async mode interactive

!

ip nat inside source list 1 interface Cellular0/0/0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0

!

access-list 1 permit any

!

dialer-list 1 protocol ip list 1

!

line 0/0/0

script dialer lte

modem InOut

no exec

DEBUG:

yourname#debug dialer

Dial on demand events debugging is on

yourname#debug chat

Chat scripts activity debugging is on

yourname#ping 4.2.2.2 source lo0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 192.168.1.100

.

May  3 15:30:55.383: Ce0/0/0 DDR: re-enable timeout

May  3 15:30:56.943: Ce0/0/0 DDR: place call

May  3 15:30:56.943: Ce0/0/0 DDR: Dialing cause ip (s=192.168.1.100, d=4.2.2.2)

May  3 15:30:56.943: Ce0/0/0 DDR: Attempting to dial lte

May  3 15:30:56.943: CHAT0/0/0: Attempting async line dialer script

May  3 15:30:56.943: CHAT0/0/0: Dialing using Modem script: lte"" & System scrip

t: none

May  3 15:30:56.943: CHAT0/0/0: process started

May  3 15:30:56.943: CHAT0/0/0: Asserting DTR

May  3 15:30:56.943: CHAT0/0/0: Chat script lte"" started

May  3 15:3.0:56.943: CHAT0/0/0: Expecting string: AT!CALL1..

May  3 15:31:01.943: CHAT0/0/0: Timeout expecting: AT!CALL1

May  3 15:31:01.943: CHAT0/0/0: Chat script lte"" finished, status = Connection

timed out; remote host not responding

May  3 15:31:01.943: Ce0/0/0 DDR: disconnecting call.

Success rate is 0 percent (0/5)

yourname#

8 REPLIES
Bronze

4G EHWICS Finally arrived! Now how to configure...

Figured it out. Was missing a space in the chat script.

New Member

4G EHWICS Finally arrived! Now how to configure...

Hey man, Im running into the same issue.  Cant seem to understand whats wrong with mine.  My profile is inactive.  Do yoiu have a way to fix it?

New Member

4G EHWICS Finally arrived! Now how to configure...

Finally got one too. We ordered it last november. Quick question for rtjensen4. In the configuration doc it states that you need a username/password for data provisioning. Did you acquire that from verizon?

Example:

router#cellular 0/0/0 lte profile create 2 apn.com chap username1 password1 ipv4

Thanks,

  Scott

Bronze

Re: 4G EHWICS Finally arrived! Now how to configure...

Nope, actually skipped the whole profile part, the default profile worked fine.

New Member

4G EHWICS Finally arrived! Now how to configure...

Thanks! That worked for me too.

New Member

4G EHWICS Finally arrived! Now how to configure...

Where was the missing space in this config.  Im having the same trouble.

Thanks

New Member

4G EHWICS Finally arrived! Now how to configure...

If you copy and paste the following you will be good to go.  You will simply need to add route statements from this point forward

chat-script lte "" "AT!CALL1" TIMEOUT 60 "OK"

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer string lte

dialer-group 1

async mode interactive

dialer-list 1 protocol ip permit

line 0/0/0

script dialer lte

modem InOut

no exec

New Member

4G EHWICS Finally arrived! Now how to configure...

In rjensen4's config there wasn't a space after the lte.

So for example the chat scrip had

chat-script lte"" "AT!CALL1" TIMEOUT 60 "OK"

instead of

chat-script lte "" "AT!CALL1" TIMEOUT 60 "OK"

12834
Views
10
Helpful
8
Replies
CreatePlease to create content