Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

5 users limitation using PPPoE on cisco??

Hello,

I am trying to use a cisco as a pppoe server. The problem is that its not able to connect mor e than 5 users at a time. I thought the cisco(3620) had some problems and used another (2610) with the same result. What could be the problem?

TIA

Shekhar Basnet

Here are some info.

System image file is "flash:c2600-ik9o3s-mz.122-31"

cisco 2610 (MPC860) processor (revision 0x203) with 61440K/4096K bytes of memory

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

PPPoE# sho run

Building configuration...

!

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group canopy-consumer

accept-dialin

protocol pppoe

virtual-template 10

pppoe limit per-vlan 300

!

interface FastEthernet1/0.630

description #### PPPoE clients #####

encapsulation dot1Q 630

pppoe enable

!

interface Virtual-Template10

ip address 192.168.125.125 255.255.255.252

peer default ip address pool consumer-pool

ppp authentication pap

!

ip local pool consumer-pool x.x.254.112 x.x.254.119

Here's a sample log when trying to connect using a 6th customer

Feb 5 16:49:53: PPPoE 0: I PADI L:ffff.ffff.ffff R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:53: PPPoE 0: O PADO L:f730.8100.0276 R:ba27.0003.e3e8 630 Fa1/0.630

Feb 5 16:49:53: PPPoE 0: I PADR L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:53: PPPoE 396: Creating

Feb 5 16:49:53: PPPoE 396: Created L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:53: PPPoE 396: O PADS L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:53: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

Feb 5 16:49:54: PPPoE 396: I PADT L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:54: PPPoE 396: Shutting down

Feb 5 16:49:54: PPPoE 396: O PADT L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:54: PPPoE 396: Destroying L:0003.e3e8.f730 R:000a.e44f.ba27 630 Fa1/0.630

Feb 5 16:49:54: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

PPPoE#sho idb

Maximum number of IDBs 300

24 SW IDBs allocated (2624 bytes each)

19 HW IDBs allocated (4976 bytes each)

HWIDB#1 1 Ethernet0/0 (HW IFINDEX, Ether)

HWIDB#2 3 BRI0/0 (HW IFINDEX, HW ISDN, Serial)

HWIDB#3 4 Serial0/0 (HW IFINDEX, Serial)

HWIDB#4 5 BRI0/0:1 (HW ISDN, Serial)

HWIDB#5 6 BRI0/0:2 (HW ISDN, Serial)

HWIDB#6 7 Serial0/1 (HW IFINDEX, Serial)

HWIDB#7 8 FastEthernet1/0 (DOT1Q, HW IFINDEX, Ether)

HWIDB#8 9 Virtual-Access1 (Serial, HW VACCESS)

HWIDB#9 10 Virtual-Access2 (Serial, HW VACCESS)

HWIDB#10 11 Virtual-Access3 (Serial, HW VACCESS)

HWIDB#11 12 Virtual-Access4 (Serial, HW VACCESS)

HWIDB#12 13 Virtual-Access5 (Serial, HW VACCESS)

HWIDB#13 14 Virtual-Access6 (Serial, HW VACCESS)

HWIDB#14 15 Virtual-Template10 (HW IFINDEX, Serial, HW VTEMPLATE)

HWIDB#15 16 Loopback0 (HW IFINDEX)

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 5 users limitation using PPPoE on cisco??

This will happen when using an ip address on the VT itself, instead make it ip unnumbered.

You have:

interface Virtual-Template10

ip address 192.168.125.125 255.255.255.252

Change to:

interface loopback 100

ip address 192.168.125.125 255.255.255.252

interface Virtual-Template10

ip unnumbered loopback 100

Please post further questions in the Ask-the -expert session I am holding.

Thanks,

Mak

5 REPLIES
bjw Silver
Silver

Re: 5 users limitation using PPPoE on cisco??

New Member

Re: 5 users limitation using PPPoE on cisco??

Keep in mind that your dhcp pool only has room for 7 clients. Make sure that you don't have an exclusion list (that part's not included in your config example) that is cutting out any of those ip addresses from the pool.

New Member

Re: 5 users limitation using PPPoE on cisco??

No there are no exclusion lists.

The pool size was expanded with the same results.

Any other suggestions?

Thanks

Shekhar Basnet

Cisco Employee

Re: 5 users limitation using PPPoE on cisco??

This will happen when using an ip address on the VT itself, instead make it ip unnumbered.

You have:

interface Virtual-Template10

ip address 192.168.125.125 255.255.255.252

Change to:

interface loopback 100

ip address 192.168.125.125 255.255.255.252

interface Virtual-Template10

ip unnumbered loopback 100

Please post further questions in the Ask-the -expert session I am holding.

Thanks,

Mak

New Member

Re: 5 users limitation using PPPoE on cisco??

Yahoooo!! Success at last.. Thanks a lot Mak. But I would love to know the reason behind it. So even changing the subnet on VT to /24 would have had no effect then?

PPPoE#sho user

Line User Host(s) Idle Location

* 66 vty 0 shekhar idle 00:00:00 x.x.233.248

Interface User Mode Idle Peer Address

Vi1 silt Virtual PPP (PPPoE ) 00:00:05 x.x.225.35

Vi2 hhc123 Virtual PPP (PPPoE ) 00:00:15 x.x.225.37

Vi3 mahaguthi Virtual PPP (PPPoE ) 00:00:55 x.x.225.33

Vi4 atlas Virtual PPP (PPPoE ) 00:00:35 x.x.225.36

Vi5 hope Virtual PPP (PPPoE ) 00:01:35 x.x.225.34

Vi6 ktptest Virtual PPP (PPPoE ) 00:00:05 x.x.225.38

PPPoE#

177
Views
0
Helpful
5
Replies
CreatePlease login to create content