Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

877W (ADSL) Connection Problem

Hello All, I am new to this community, if this group is not a correct one to post this please guide me to the one that I can post. I have acquired an 877W ADSL router in almost mint condition. Have gone through the express SDM and configured it, but I can't get any activity nor do I get any connectivity. Have been checking my steps through SDM(Not express any more) and all seem to be OK. Have been working and I think the issue is negotiation ATM0.1. The physical router has the OK light solid green and the CD light flashing pretty rapidly. I am wondering if somebody from this group can put me in a right track or point out from the below running config what is missing or not.

IOS version: 12.4(2)T5

SDM version: 2.4

28 REPLIES
Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Forget about the SDM.

Send "show dsl interface"

New Member

Re: 877W (ADSL) Connection Problem

I can't say I disagree with you when it comes to SDM and initial configuration. I get error when "show dsl interface" however I tried

cisco-877w#show dsl interface ATM 0

Alcatel 20196 chipset information

Line has not yet been activated. No information available.

DSL: Training log buffer capability is not enabled

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Try newer adsl 3.0.33 firmware from

ftp://cisco.com/pub/access/800

note you need

ip nat inside (on bvi)

ip nat outside (on dialer)

ip nat inside source list 1 interface dialer0 overload

access-list 1 permit 192.168.1.0 255.255.255.0

and you've the wrong values for mtu and few other stuff

but, first things first, adsl has to come up.

New Member

Re: 877W (ADSL) Connection Problem

p.bevilacqua First off bless your hart for helping me. I don't know how to thank you, let me start working on your list in next couple of days and I will post once I am done with the new running config so you can assess........Once again Thank you.....

Ardy

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

No worries, we make it work then you can use the scrollbox below to rate useful posts.

New Member

Re: 877W (ADSL) Connection Problem

Thanks, Ardy, for making me aware of your post. I probably put mine under the wrong topic. Help from anyone is of course appreciated. I will watch your post.

Cheers

uli

New Member

Re: 877W (ADSL) Connection Problem

OK....I copyied the said firmware 3.0.33 to the flash...reboot the 877 and confirm the file was there(See attechment 1)

New Member

Re: 877W (ADSL) Connection Problem

bevilacqua:

I pressed the post instead of Add Attachment. then I proceeded with the "show dsl interface ATM 0" and got the same message not what I expected....I got "Alcatel 20196 chipset information

Line has not yet been activated. No information available.

DSL: Training log buffer capability is not enabled"

I was expecting to see version numbers.....is this OK, should I proceed to the rest of items you mentioned ........

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

No it's not normal, have you reloaded the router ?

New Member

Re: 877W (ADSL) Connection Problem

Yes....I did reboot. I am jot a router expert, but could it be that the IOS is corrupt in one form or fashion. would we get a clean slate if we re-install the IOS that comes with the proper Firmwear and start fresh.

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Yes try replacing IOS, as you can see in the thread next to this one, some more information has to be reported.

New Member

Re: 877W (ADSL) Connection Problem

I will do that next. knowing that model numbers and IOS's are pritty involved and kind of hard to dijest for fresh eyes to recognize. what would be the version I am after? and do I need to do two seperate upload one IOS and one Firmwear or hopefully the IOS upload will have the IOS. Do you happen to know the link I Need to get this from......

my Model is 877W current Version I am running is 12.4(2)T5

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

I guess you would not have access anyway to downloads.

Let me think if I can find a reason why it's not working for you and I'll get back to you.

New Member

Re: 877W (ADSL) Connection Problem

I can't say I disagree with you when it comes to SDM and initial configuration. I get error when "show dsl interface" however I tried

cisco-877w#show dsl interface ATM 0

Alcatel 20196 chipset information

Line has not yet been activated. No information available.

DSL: Training log buffer capability is not enabled

DId u read this message?

Line has not yet been activated

I hope got it? The CD light flashes rapidly means router is trying to train up and is failing ddue to line sync issues. I wld make sure dsl service was actually active on tht line and if it is there is sme blocking the adsl signal. Depending on where your demarc is get the telco or ur cabling guy involved.

New Member

Re: 877W (ADSL) Connection Problem

I have done couple of debug commands since my last communication to this group. the result was that it seems that it wants to negotiate with the providers equipment(most likely the DSLAM) but it fails.....

I also have talked to my provider COVAD and they told me that even the hardwear is not supported by them, meanning they don't want to support in terms of scripting and out of the box solution but they have other customers that thire CISCO have been working. So be as it may I haven't gave up.

New Member

Re: 877W (ADSL) Connection Problem

Did u ever have adsl on this line or this a fresh install? I hope ur telephone service is active on the line!!!unless this is naked DSL.

I am sure if this is afresh install the installer must hv proved the service is working before leaving rite? Where is the socket installed? Is it the same place u r connecting the 877? Try a different rj11 cable (maybe even a the router though i doubt it) and if u still don't get line sync log a no sync fault and make them come out and get sync with their modem.

Run debug atm events to see layer 1 and if u don't see showtime get on the phone since something is seriously broken.

I hv had just once case where the customer was using a faulty power supply. The cisco never trained up and we spent a week wondering what was wrong:)

New Member

Re: 877W (ADSL) Connection Problem

No this is not a fresh install. I had this connection for past 8 years(5 static IP), it is an up and down 768k. My existing router is getting old and I am swiching to cisco.

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Go ahead and install newer adsl fw

ftp://ftp.cisco.com/pub/access/800

you want 3.0.33

New Member

Re: 877W (ADSL) Connection Problem

Hello P.bevilacqua:

I did this back in Sep-21st after your initial suggestion. Since then I have started all over again building a new configuration not having to do any thing with SDM. As you know as soon as you start using it it adds stuff to your config. Anyhow...the latest config is attached to this post. Also I have attached a debug for ATM0. one of my freands tend to think the issue is in layer one. Either the Dialer or ATM configuration. from the debug it seems that the ATM0 wants to connect but is not negotiating.

I have question for you. lets forget all abt connections and configurations for one moment. this router has an built in modem that dose the initial connection to the providres(COVAD) Designated DSLAM(which is in the telco facility. How would I test just the modem to assure it is working like it suppose to? just the hardwaer?

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

It is not a configuration issue.

Simply for some reason adsl does not synch up. You can easily try connecting it to any other circuit, ATM interface goes up and CD light is steady on.

New Member

Re: 877W (ADSL) Connection Problem

I noticed a couple of things. I have attached what I ran on my 877W. I had a bear of a time getting things going.

At the time I was with Qwest.

I hope this helps

John

New Member

Re: 877W (ADSL) Connection Problem

Thnaks for the post......I will try this in next few days.

It has to be configuration problem, if not than it must be hardwear. do any of you know how to test the modem. I will get to the buttom of this one way or another, I will keep you guys posted on the progress.

Regards

Ardy

Ardy

New Member

Re: 877W (ADSL) Connection Problem

Honestly, I do not know of any way to test the modem. What I can tell you is - IF your configuration is not correct, the modem WILL NOT sync up.

I came off a site today where support sent out an new 2811 with T1 and ADSL (as a backup) because the original would not work. the new router displayed the same symptoms as the old ... No Sync! There was a stand-alone modem still in the rack, un-used and it sync'd just fine. when I asked the support contact if they had config'd ATM0 and ATM0.1 as I would try setting things up using DHCP to begin with and then migrate to to the Static IPs you currently have once you get things working.

John

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

IF your configuration is not correct, the modem WILL NOT sync up.

That is not correct. No matter the configuration, the circuit will always come up, but not pass data. Your problems with with the 2811 are due to something else. It is well know that unfortunately, sometime cisco adsl interface do not sync up where a $15 modem does.

New Member

Re: 877W (ADSL) Connection Problem

Thanks John:

I will try the new config you have send me......

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Have you ever resolved this ?

I just realized that FW 4.0.15 is the latest and you should try it.

New Member

Re: 877W (ADSL) Connection Problem

Oh my god.

The issue was so simple, I feel so stupid.....The equipment is an ADSL modem my service from COVAD is SDSL, So go figure....I am curently looking into changing my Service provider since COVAD is not very cooperative in swiching my SERVIVE and keeping my current IP's or swiching and getting new ip's , they only deal with dynamic ip's when it comes to ADSL, looking into MEGAPATH now they seem to be able to provide what I need.

Ardy

Hall of Fame Super Gold

Re: 877W (ADSL) Connection Problem

Thank you for letting us know!

4156
Views
4
Helpful
28
Replies
CreatePlease to create content