Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

ADSL - TISCALI(UK) - WOES ON A 827

Recently Tiscali upgraded their service and changed from aa5snap to aal5mux. there was no notification of this and I had to figure this out when things fell apart. see:

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddd7f2e/1

About 5 days later, problems started again.

While surfing, I only get partial pages downloaded before page freezes. Speeds on downloads at about 4Kbps!. Funny thing though, is that Google search is same speed as always.

Again tiscali insists nothing has changed. I know for CERTAIN I did not change my config.

I plugged in a USRobotics router and another Cisco 827 and I encounter the exact same problems so it is not unique to my hardware. With tiscali supplied speedtouch modem, things are full speed.

speedtouch modem default mtu is same as cisco default - 1500. Anyhow, I played around with mtu settings. but made no difference, also pppoa which I am on, is not susceptible to mtu it seems. However, I do not want to rule this out.

do I need to set max receive unit on cisco to 1500? if so how? it is set to 1500 on speedtouch modem.

Can somebody please advise on where I would start to debug this problem.

Kind regards. attached is config

Building configuration...

Current configuration : 911 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

ip name-server 212.139.132.22

!

!

!

!

interface Ethernet0

ip address 10.254.0.100 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname unhappy@tiscali.co.uk

ppp chap password 0 123456789abc

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

!

access-list 1 permit 10.254.0.0 0.0.0.255

!

line con 0

stopbits 1

line vty 0 4

login

!

scheduler max-task-time 5000

end

3 REPLIES
Silver

Re: ADSL - TISCALI(UK) - WOES ON A 827

I have seen symptoms like yours solved by adding "ip tcp adjust-mss 1349" to the internal interface. Also add an MTU command to the dialer interface.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a00804247fc.html

New Member

Re: ADSL - TISCALI(UK) - WOES ON A 827

Ahmed,

SPOT ON!

Is 1349 an arbitrary number, where any range between 500 & 1460 is likely to work?

thank you!

Phil

Silver

Re: ADSL - TISCALI(UK) - WOES ON A 827

Phil,

I've seen it somewhere on here. I suspect it is the result of trial and error. I also suspect other numbers in the same nieghborhood will work too.

You don't want to set it too low for efficiency reasons.

345
Views
5
Helpful
3
Replies
CreatePlease to create content