Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AS5300 in POS environment

We have a AS5300 loaded with MICA modems and 4xT1 card. POS terminals dialup to the AS5300 and fork a telnet stream to a host target HOST_A on a specific port. Here is a snippet of how my lines are configured

ip host HOST_A 1075 192.168.1.2

!

!

modemcap entry POS_TERMINAL:MSC=&F&D2S0=0S15=0S21=0S22=0S23=0S24=0S29=4S30=2400S31=1200S52=0S53=0S54=32968S64=10

!

!

line 1 48

no motd-banner

no exec-banner

exec-timeout 0 0

no flush-at-activation

no vacant-message

modem InOut

modem autoconfigure type POS_TERMINAL

autocommand telnet HOST_A /stream /noecho /quiet

no activation-character

transport input all

transport output all

escape-character NONE

dispatch-timeout 1500

My problem is that the AS5300 sends several extra DEL (Delete) characters which cause the POS terminal to reject transactions. Below is the output of a capture from a RS232 protocol analyzer

Data received: <CR><LF>OK<CR><LF>

Data received: <CR><LF>OK<CR><LF>

Data received: <CR><LF>OK<CR><LF>

Data received: <CR><LF>OK<CR><LF>

Data received: <CR><LF>OK<CR><LF>

Data received: <CR><LF>CONNECT<Space>38400/NONE/1200<CR><LF><Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>

Data received: <Delete>|

Data received: <ENQ><NUL>

Data received: <STX>XXXXXXXXXX<FS>0000090<FS>0000036<FS>001<FS>82

Data received: 5<Space><Space><Space><Space><Space><Space><Space><Space><Space>$0.36<FS>0000<ETX>@

Data received: <EOT><NUL>

Data received: <FF>c?

I believe these delete characters are part of the telnet protocol specs, but I could be wrong, because the "stream" option should send the data in a raw tcp stream. Anybody have any ideas on how to remove the extra DEL characters from the stream or maybe there is another way to do this without using the "modem autoconfigure" option.

--

Matteo D'Amato

Manager, Systems Applications & Development

Smartbox Equipment Inc

4 REPLIES
Silver

Re: AS5300 in POS environment

Matteo,

I know you've asked this question before, here and on comp.dcom.sys.cisco. Below your post you can see an "ASK THE EXPERT" thread where an expert from cisco is answering questions about AS5X00 problems. I suggest you post your question there.

New Member

Re: AS5300 in POS environment

I tried Zulfiqar's suggestion in "ASK THE EXPERT" to test if my host was in telnet mode by trying:

telnet HOST_A /debug

and I can confirm that HOST_A is not in telnet mode. Other people have suggested shortening my modem INIT string. When I set it to:

POS_TERMINAL:MSC=&F&D2S0=0S29=4S21=0S22=0S23=0S24=0

I do see fewer delete characters sent. This was the only change that actually had an effect on the delete characters. Does anyone have other suggestions. Thanks

New Member

Re: AS5300 in POS environment

With the above modem INIT string the deletes seem to be part of the connect message sent by the MICA modems.

Data received: CONNECT38400/NONE/2400

Data received:

Data received: ********00002200003122001857122$31.220000Q

Data received:

Data received: F??wwwwwww

Data received: NOCARRIER

Is there a way to set the modems in quite mode so that it doesn't send the connect message? Maybe this will remove the extra delete characters.

--

Matteo D'Amato

Smartbox Equipment Inc

188
Views
0
Helpful
4
Replies
CreatePlease login to create content