Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AS5350 w/ "4 T1 PRI" board, modem issues

I've never worked with the Universal Gateway product line, so forgive my ignorance.

We have a "4 T1 PRI" board installed. A technician from the vendor who sold the equipment did basic setup. We plan on using it via the Hayes AT command set. The tech said that is old technology, and rarely used. But, that is what we plan on.

First question would be to find out exactly what AT commands it supports. I found to documents that looked promising, "AT Command Set and Register Summary for Cisco MICA Six-Port Modules" and "AT Command Set and Register Summary for Microcom Modem Modules". Both are Cisco documents in the AS5300 series documentation. I suppose they pertain to different modem modules. I'm not sure which (if either) apply to the specific module we have, the 4 T1 PRI board.

Basic AT commands, like the standard ATDT command works okay. Some of the more obscure things I found in the document for the Microcom modem manual, such as setting parity seemed to be rejected. Therefore, I make the educated guess that document isn't the right one for me.

The application for the 5350 is a SCADA system. That is basically a data collection application, where it dials hundreds of remote locations to obtain tank level data and the like. Some of the remote sites have ancient 2400 baud modems. The slow baud isn't a factor as the data transfer at even that speed takes only a couple of seconds.

So, here are the issues I have so far:

1. I'm receiving binary data. At least when connected at 2400 baud, if the data being received happens to have a carriage return character, or the 8D (hex) character, I get an extra null byte in the data stream. I'm fairly certain this problem is within the Cisco unit, as I can dial the exact same site with the exact same software, except using an off-the-shelf consumer modem, and it works fine. I haven't tested it enough yet to determine if the issue is limited to only the 2400 baud connections or not.

2. Some of the remote sites have odd-ball parity requirements, like 8 data bits plus even parity. This is known as 11-bit mode. I need to be able to configure this.

Thanks for any help!!!

5 REPLIES
Bronze

Re: AS5350 w/ "4 T1 PRI" board, modem issues

The following baud-rate limitations apply to the slow-speed serial interfaces in the asynchronous/synchronous serial modules:

Asynchronous interfaceMaximum baud rate is 115.2 kbps.

Synchronous interfaceMaximum baud rate is 128 kbps, full-duplex.

New Member

Re: AS5350 w/ "4 T1 PRI" board, modem issues

Thank you for replying. But, I'm confused as to how this information pertains to my questions. I did get some more information, which I will post as a separate follow-up.

New Member

Re: AS5350 w/ "4 T1 PRI" board, modem issues

As an addendum, I've found out some additional information. I now know that I have what are called NextPort modem modules. These have a different AT commant set then the other two documents I had come across earlier. But, there are S registers to do the odd-ball parity settings I need with the NextPort modules. So, I've got the answer to my question 2.

But, I don't know what is going on with question 1. I haven't worked on the unit since my posting, as I was on vacation last week. But I'll need to dig up something quick next week.

New Member

Re: AS5350 w/ "4 T1 PRI" board, modem issues

Faairly old post, so maybe you've resolved your problems, but here are a few pointers anyhow.

The 4 TI PRI board is not related to the modems - this is the Telco interface. If you "sh diag" there will be some modems boards installed. Look for keywords like SPE or NS60.

The AT command set does take a little getting used to on these and the NM-16AMs are different again!!

I have configured a similar async system (no IP) for a meter reading application - similar to SCADA. You need to be carefull what port you reverse telnet to. Port 2xxx, 4xxx and 6xxx will yield different results. 7 bit, 8 bit, odd parity and event parity work OK on our AS5350, but you need to be aware that there is no AT&W command and that you must set up the modems from your application or using a modemcap entry. Not sure about 11 bit mode, that sounds like it might be an old Conitel protocol, which used "true" analogue 1200 bps modems. It's highly unlikely that the AS5350 would support that.

New Member

Re: AS5350 w/ "4 T1 PRI" board, modem issues

Thanks for responding. Yes, it is an old post, and I got my situation resolved. "11 bit mode" is one type of terminology to mean 8 data bits plus parity. That would be 9 bits, but in the terminology I was speaking of, the start and stop bits are counted giving 11 bits. Some CSU/DSU's use that terminology. But if you aren't familiar with that terminology, forget I said it and just know that I mean 8 data bits plus parity.

Bottom line is, you said you got 8 databits plus parity to work. I wasn't able to, but I was able to get the end devices to accept 8 data bits no parity. Even so, I'd like to know how you got 8 data bits plus parity to work, for future reference, in case I need it in the future. I understand there are some Cisco CLI commands that might be related to doing this. There were some modem S registers that seemed like it might do that, but I couldn't get that to work.

259
Views
2
Helpful
5
Replies
CreatePlease login to create content