Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Backup ISDN Problem

Hi, I have a very strange problem, wondering if anybody has seen this before. I have two sites connected together with a serial line and using isdn backup. The serial part is working fine. I should clarify, I am using 2 x 2600's running 12.3 IOS. I am using a floating static to bring up the ISDN. My problem is that once the line comes up the first time and drops, it won't come up anymore. The ok light on the BRI card goes out, layer 1 is deactivated and it won't come back up. The way I have made it come back up is to ring the ISDN number on both sides from my mobile phone, I get a green light again on the ok and then if I pull the serial it will come up ok. This actually happens on both sides. I done a debug and saw the following error when the line drops:

*Mar 1 23:55:42.496 UTC: ISDN BR0/0 **ERROR**: host_disconnect_ack: Unfound B-c

hannel on Disconnect_Ack call id 0x802D.

*Mar 1 23:56:04.473 UTC: ISDN BR0/0 **ERROR**: CCBRI_Go: NO CCB Src->HOST callid 0x802D, event 0x5 ces 1

Does this mean anything to anyone? I have tried the output interpreter and found nothing.

Cheers

Brian

4 REPLIES

Re: Backup ISDN Problem

Hello Brian,

sounds like either an IOS bug, or an issue with yur TELCO (ISDN switches). Can you try the following:

make a conection using the 'isdn test' command, and then disconnect using the 'isdn test disconnect' command, see if that makes a difference. If you can connect after that, the issue could be with your Telco (some older ISDN switches do not properly disconnect sessions). Can you post your configs (just in case, there might be an issue) ?

Regards,

GNT

New Member

Re: Backup ISDN Problem

Hi GNT,

Here is the relevant bits of my config:

aaa authentication ppp default local

username farside password xxxxx

isdn switch-type basic-net3

interface BRI0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface Dialer1

ip address 10.10.10.5 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name Farside

dialer idle-timeout 200

dialer string XXXXXXXX

dialer load-threshold 128 either

dialer-group 1

ppp authentication chap

ppp multilink

!

ip route 0.0.0.0 0.0.0.0 10.10.10.6 250

access-list 100 permit ip 10.1.1.32 0.0.0.31 any

dialer-list 1 protocol ip list 100

I tried the isdn test but it didn't bring up the line. I have found something new however. If I wait for 15 mins after the line has dropped and ok light has gone out, layer 1 will come up again and I can failover again no problem. It is like the Telco is not releasing the line for my use again!

Cheers

Brian

New Member

Re: Backup ISDN Problem

Also, the username and remote-name are actually the same case!

Re: Backup ISDN Problem

Hello,

one thing: try and add the 'ppp multilink' to your physical interface as well:

interface BRI0/0

ppp multilink

and see if that makes a difference...

Regards,

GNT

119
Views
0
Helpful
4
Replies