Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BRI connects then disconnects after 20 seconds

We have a central router connecting to several remote sites. Central router is configured never to dial out.

One of the remote routers has been working ok via a BRI for several months.

We then changed it onto a new BRI - all configurations staying the same.

Now it can make a connection, but then the central router closes the call in a normal fashion.

debug isdn q931 on the remote router yields following when it dials out:

6d14h: ISDN BR1/0: TX -> SETUP pd = 8 callref = 0x32

6d14h: Bearer Capability i = 0x8890

6d14h: Channel ID i = 0x83

6d14h: Called Party Number i = 0x80, '01709840009', Plan:Unknown, Type:U

nknown

6d14h: ISDN BR1/0: RX <- CALL_PROC pd = 8 callref = 0xB2

6d14h: Channel ID i = 0x89

6d14h: ISDN BR1/0: RX <- ALERTING pd = 8 callref = 0xB2

6d14h: ISDN BR1/0: RX <- CONNECT pd = 8 callref = 0xB2

6d14h: ISDN BR1/0: HOST_CONNECT: VOICE ERROR: Bearer capability not available(0x

3A): bchan 0, call id 0x89D7

6d14h: ISDN BR1/0: TX -> CONNECT_ACK pd = 8 callref = 0x32

Caller ID hasn't been configured on the Central Router.

I can only assume its something up with the ISDN cloud.

Any help is very welcome.

Andy Greaves

4 REPLIES
VIP Purple

Re: BRI connects then disconnects after 20 seconds

Hello Andy,

did you exchange just the BRI card, or did you also install a new/other router ? Can you post the output of ´show version´, as well as the configuration of the router, if possible ?

Regards,

GP

New Member

Re: BRI connects then disconnects after 20 seconds

Hi Andy,

the following output stands out in my opinion:

"6d14h: ISDN BR1/0: HOST_CONNECT: VOICE ERROR: Bearer capability not available(0x

3A): bchan 0, call id 0x89D7"

It does appear that the Carrier has changed this circuit to use Voice and not Data. 90% of the time when we've had the 20 second disconnect it has been a Carrier issue. 10% it has been a ISDN card problem. Since all you did was change to a new BRI, I would concentrate on the problem being a Carrier issue.

HTH,

Steve

New Member

Re: BRI connects then disconnects after 20 seconds

Steve,

Thanks for replying.

We have already contacted the CO as I'm sure they've set the new BRI incorrectly.

I just wanted to get peoples input on the error message.

Regards

New Member

Re: BRI connects then disconnects after 20 seconds

Hi,

One more thought. You said that you have placed a new BRI card. Is this by any chance VWIC? If so, if might be interpretting your data connections as being voice calls and drops the carrier. Try using "isdn incoming-voice data" command under the BRI interface and see if it improves the matter.

I had similar issue using Cisco's AS5300 when I once forgot to configure this command under the proper interface and all dialing users (using analog modems) would get disconnected due to a fact that AS would consider the calls as being voice.

David

686
Views
0
Helpful
4
Replies
CreatePlease login to create content