Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

C3640: ISDN Dialin-Problems after IOS-Update

Hi,

after updating the IOS on a 3640 router

from

c3640-i-mz.120-7.T.bin

to

c3640-i-mz.122-31.bin

I had following problems:

- analog dialin didn't work anymore

- isdn dialin without callback didn't work anymore

- isdn dialin with callback still worked.

Here's the relevant part of the config:

ip address-pool local

virtual-profile virtual-template 1

virtual-profile aaa

isdn switch-type primary-net5

isdn voice-call-failure 0

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T"TIMEOUT 30 CONNECT \c

chat-script dataport-v32 "" "ats0=1&c1&d2\\q3\\n7%c1" "OK" \c

!

controller E1 2/0

pri-group timeslots 1-30

!

controller E1 2/1

pri-group timeslots 1-30

!

interface Loopback0

ip address 192.168.13.1 255.255.255.0

!

interface Ethernet0/0

ip address 192.168.0.12 255.255.255.0

!

interface Serial2/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

isdn switch-type primary-net5

isdn incoming-voice modem

peer default ip address pool TravelUser

fair-queue 64 256 0

ppp callback accept

ppp authentication chap

ppp multilink

!

interface Serial2/1:15

no ip address

no ip directed-broadcast

isdn switch-type primary-net5

isdn guard-timer 3000

fair-queue 64 256 0

!

interface Virtual-Template1

description fuer ISDN Dial in

ip unnumbered Loopback0

ip mroute-cache

load-interval 30

peer default ip address pool TravelUser

ppp callback accept

ppp authentication chap

ppp multilink

!

interface Group-Async1

no ip address

encapsulation ppp

load-interval 30

dialer in-band

dialer-group 1

async mode interactive

peer default ip address pool TravelUser

no fair-queue

ppp callback accept

ppp authentication chap

ppp multilink

group-range 97 108

!

ip local pool TravelUser 192.168.13.11 192.168.13.70

ip local pool vpn 192.168.13.111 192.168.13.170

ip route 0.0.0.0 0.0.0.0 192.168.0.1

!

map-class dialer rueckruf

dialer callback-server username

dialer-list 1 protocol ip permit

tacacs-server host 10.10.10.28 single-connection

!

line 97 108

session-timeout 120

exec-timeout 0 0

autoselect ppp

script modem-off-hook offhook

script arap-callback arap-callback

script callback callback

modem InOut

modem autoconfigure discovery

transport preferred telnet

transport input all

flowcontrol hardware

Maybe it's just a missing command which was default in the old IOS and isn't in the new.

By the way: I played back the old IOS and it works again like before.

Any ideas?

Thanks in advance

Rolf Fischer

4 REPLIES
Bronze

Re: C3640: ISDN Dialin-Problems after IOS-Update

issue the following command in the previlege level mode

hostname#debug isdn q921

hostname#debug isdn q931

and see the messgaes recieved

New Member

Re: C3640: ISDN Dialin-Problems after IOS-Update

Rolf,

I am having the same issues on 2 3640s. I am observing connection lockups after 30 seconds to two minutes of activity following an upgrade to c3640-i-mz.124-13a. I will post debug info later today after we coordinate some testing.

Sincerely,

Paul Smith

New Member

Re: C3640: ISDN Dialin-Problems after IOS-Update

Paul,

thank you - I'm looking forward for your post.

We're running the 'old' IOS again because our travelling users need to dial in.

Regards

Rolf

New Member

Re: C3640: ISDN Dialin-Problems after IOS-Update

Rolf,

We are having some success with 12.4(8c). I want to wait until after the weekend (when we have tons of RAS) before I declare victory.

Sincerely,

Paul

133
Views
0
Helpful
4
Replies