Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Call back RAS

Dear All,

I have a router Cisco 2610 for remote call, the user authentication dial up to connect network use Tacac.

The user account can already make call back to other router, but not with my Cisco 2610.

every time user dial, he directly connected with no call back.

Could anyone help me to make it work as I want ?

Here is the sotfware image:

IOS (tm) C2600 Software (C2600-IS56I-M), Version 12.0(10), RELEASE SOFTWARE (fc1)

and here is the configuration:

Building configuration...

Current configuration:

ip address-pool local

async-bootp dns-server 10.234.0.29

async-bootp nbns-server 10.234.0.1

chat-script dial "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c

chat-script offhook "" "ATH1" OK

!

!

!

!

interface Ethernet0/0

ip address 192.168.20.1 255.255.255.252

ip helper-address 10.144.192.41

ip helper-address 10.144.192.2

no ip directed-broadcast

no ip mroute-cache

!

interface Async33

description RAS

ip unnumbered Ethernet0/0

ip helper-address 10.144.0.10

ip helper-address 10.144.192.2

ip helper-address 10.134.192.41

no ip directed-broadcast

encapsulation ppp

async mode interactive

peer default ip address pool RAS

ppp callback accept

ppp authentication pap

!

interface Async34

description RAS

ip unnumbered Ethernet0/0

ip helper-address 10.144.0.10

ip helper-address 10.144.192.41

ip helper-address 10.144.192.2

no ip directed-broadcast

encapsulation ppp

async mode interactive

peer default ip address pool RAS

ppp callback accept

ppp authentication pap

!

!

ip local pool RAS 192.168.21.1 192.168.21.10

ip classless

ip route 10.144.0.0 255.255.0.0 192.168.20.2

ip tacacs source-interface Ethernet0/0

!

tacacs-server host 10.144.0.5 key routerpdn2

snmp-server community Ciscoumum RO 5

snmp-server community Ciscosendiri RW 5

radius-server host 10.144.0.5 auth-port 1645 acct-port 1646

radius-server timeout 20

radius-server key xxx

!

line con 0

exec-timeout 0 0

password xxx

transport input none

line 33 40

autoselect during-login

autoselect ppp

script connection callback

script modem-off-hook offhook

script callback callback

modem InOut

transport input all

callback forced-wait 5

flowcontrol hardware

line aux 0

exec-timeout 0 0

password xxx

modem InOut

transport input all

flowcontrol hardware

line vty 0 4

access-class 100 in

password xxx

!

Thanks and Best regards,

Coi

4 REPLIES
New Member

Re: Call back RAS

Hi Coi

Just try "ppp callback permit" instead of "ppp callback accept".

New Member

Re: Call back RAS

Hi Stephen,

Here are the choises available for the command "PPP callback....."

1. accept Accept a callback request

2. initiate Initiate callback without PPP callback negotiation

3. request Request a callback

Callback permit is not available.

Thank and regards,

Coi

New Member

Re: Call back RAS

Sorry

Didn't see you're using IOS 12.0

The command was introduced later...

You wrote that your client can do callback at another router.

Ist it using the same AAA Server?

If not. Are Callback (Dialup client specifies callback number) and TACACS+ PPP settings (PPP IP, PPP Multilink, PPP LCP) the same?

Stephan

New Member

Re: Call back RAS

Hi Stephan,

I am using the same AAA server, and tacas+PPP setting PPP IP and PPP LCP.

Thanks,

Coi

239
Views
0
Helpful
4
Replies
CreatePlease login to create content