Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

callback problem between Cisco router and MS XP client

Hello,

I am configuring callback between a cisco 3725 router and a dialup Microsoft XP client.

Here is the router configuration :

aaa new-model

!

!

aaa authentication login userauthen local

aaa authentication ppp default local

aaa authorization network groupauthor local

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT\T" TIMEOUT 60 CONNECT \c

!

username test callback-dialstring "" password xxx

interface Loopback0

ip address 172.20.8.1 255.255.255.0

interface Serial0/1

physical-layer async

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 0 either

dialer-group 1

async mode dedicated

peer default ip address 172.20.8.200

keepalive 40 3

ppp callback accept

ppp authentication pap chap callin

ppp authorization groupauthor

dialer-list 1 protocol ip permit

!

line 2

script modem-off-hook offhook

script callback callback

login authentication userauthen

modem InOut

modem autoconfigure discovery

transport input all

autoselect ppp

speed 115200

flowcontrol hardware

Here is problem :

- Without the command ppp callback accept, the ppp connection works properly

- When enabling callback, the client and the router agree on callback, the router disconnects and then reconnects, the interface comes up and then the router sends several CONFREQs with no response before disconnecting.

In the meanwhile, running windump on the calling client, shows that the client itself sends 8 CONFREQs with no response from the router. I tried with a Win 98 client and the behaviour is the same (from the router side at least).

Could you have a look at the configuration and tell me where the problem comes from ?

Thank you in advance.

  • Remote Access
1 REPLY
Silver

Re: callback problem between Cisco router and MS XP client

A PC user (client) connects to the Cisco access server.

Callback process is negotiated in the Point-to-Point Protocol (PPP) link control protocol (LCP) phase.

PPP authentication is performed.

The Cisco IOS software validates callback rules for this user or line and disconnects the caller for callback.

The Cisco access server dials the client.

There are four types of MSCB:

No callback.

User-specified callback number.

Server-specified (preconfigured) callback number.

List of preconfigured callback number

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

101
Views
0
Helpful
1
Replies
This widget could not be displayed.