Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Callback problem

hi!

can any onr help me with a callback problem. Pc dialing into router via ISDN doesnt work with callback but works without it.

6 REPLIES

Re: Callback problem

Hello,

can you post the configuration of your router as you have configured it so far ?

Regards,

GNT

New Member

Re: Callback problem

modem country mica south-africa

aaa new-model

!

!

aaa authentication ppp default group radius local

aaa authorization exec default local group radius

aaa authorization network default local group radius

aaa accounting network default start-stop group radius

aaa session-id common

ip subnet-zero

ip cef

!

!

!

no ftp-server write-enable

async-bootp dns-server 192.168.101.2 192.168.101.3

async-bootp nbns-server 192.168.101.2 192.168.101.3

isdn switch-type basic-net3

!

chat-script callback ABORT ERROR ABORT BUSY "" "ATDT\T" TIMEOUT 30 "CONNECT" \c

chat-script offhook "" "ATH1" OK

modemcap entry 3com_usr:MSC=&F1S0=1

!

!

!

interface FastEthernet0/0

ip address 192.168.254.250 255.255.255.0

no ip redirects

no ip unreachables

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.100.28 255.255.255.0

no ip redirects

no ip unreachables

duplex auto

speed auto

!

interface BRI2/0

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

isdn skipsend-idverify

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/1

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/2

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/3

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/4

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/5

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn incoming-voice modem

no keepalive

ppp authentication pap chap ms-chap

!

interface BRI2/6

no ip address

isdn switch-type basic-net3

!

interface BRI2/7

no ip address

isdn switch-type basic-net3

!

interface Group-Async1

ip unnumbered FastEthernet0/1

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 900

dialer-group 1

async dynamic routing

async mode interactive

peer default ip address pool RAS

ppp max-bad-auth 3

ppp callback accept

ppp authentication ms-chap-v2

group-range 33 50

hold-queue 10 in

hold-queue 20 out

!

interface Dialer0

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 900

dialer-group 1

peer default ip address pool RAS

ppp authentication ms-chap-v2

ppp multilink

ppp callback accept

hold-queue 10 in

hold-queue 20 out

!

ip local pool RAS 192.168.103.230 192.168.103.254

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.1

ip http server

!

dialer-list 1 protocol ip permit

radius-server host 192.168.101.61 auth-port 1645 acct-port 1646

radius-server key xxx

radius-server vsa send authentication

!

line con 0

password xxx

line 33 50

session-timeout 10

script modem-off-hook offhook

script callback callback

modem InOut

modem autoconfigure discovery

autoselect during-login

autoselect ppp

line 51 62

line aux 0

line vty 0 4

password xxx

!

end

Re: Callback problem

Hello,

the config looks ok, as far as I can tell. Can you post the output of:

debug modem

debug chat

debug callback

Regards,

GNT

New Member

Re: Callback problem

hi!

i have go the callback to work up to the point where it asks me to put in the number tocall back.

the router then disconnects the session but doesnt initiate a callback.

there is nothing on the debugs that you requested.

Re: Callback problem

Hello,

can you try the following callback script:

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

and see if that makes a difference ?

Regards,

GNT

New Member

Re: Callback problem

hi!

i have manged to get it working. seems the router didnt know which interface to dial out on. once iadded the line "modem dialout int bri 2/0" it worked fine.

thanks for the help.

130
Views
0
Helpful
6
Replies
CreatePlease login to create content