Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Can't remote router using SSH and Telnet on cisco 1941

First off all, i'm sorry if my english is not good and i'm new in networking ecspecially on CISCO.

I have configured my cisco 1941. i have enabled line 0 4, but still i can't connect using SSH or Telnet.

Here my configuration:

Building configuration...

Current configuration : 5196 bytes

!

! Last configuration change at 04:21:03 UTC Mon Nov 4 2013 by admin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname HO-METRO-DURI

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 4 pbTc9WvAVEgPZL9NCovQTXULvOXiW1Fb7lJABZEwJyw

!

no aaa new-model

!

ip cef

!

!

!

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

!

ip domain name yourdomain.com

no ipv6 cef

multilink bundle-name authenticated

!

!

crypto pki trustpoint TP-self-signed-3627276910

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3627276910

revocation-check none

rsakeypair TP-self-signed-3627276910

!

!

crypto pki certificate chain TP-self-signed-3627276910

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363237 32373639 3130301E 170D3133 30373139 30383535

  35375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36323732

  37363931 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81008B96 B231D09A 36DD8274 8EC98593 9DAF654D 1667C877 45AAB9BF AFFE6C51

  0EF0C859 D15B9523 0F3BC569 79CD23DA A62FBE13 1F27469C 120D701F 7FBCCE97

  B53F1E58 11B711AB 73E83ABB D4472C15 2F917C48 45D3B638 66409655 84600AC0

  57C6AB95 51A12CBA A6D53D7B B3E8FA43 69CCF25E FBBD4102 B0D295A2 A651B604

  9D6B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 144C5F0C 58E99981 359FE96E FC79ADEF 60EE3FFA 84301D06

  03551D0E 04160414 4C5F0C58 E9998135 9FE96EFC 79ADEF60 EE3FFA84 300D0609

  2A864886 F70D0101 05050003 8181004D EED4759E 30A21C3E A1E4E8B7 6F001F86

  BA3C456C F208A4CC F3A3AD98 249C6DFF BEC9305A 596CC499 B187A224 D6E74445

  E7A5C063 5C5B7D2B C7BDB4E4 B0ECA001 432985BD B7BBABE4 C7D78245 3B77EBC8

  0E402C49 54209F0F 577A826F EA46318F 293C8E17 43D49128 2A43F0DF 591551BE

  0A7BC9A6 8DEDCEE8 815E829F CCAC3A

        quit

license udi pid CISCO1921/K9 sn FGL1729248K

!

!

username admin privilege 15 secret 4 pbTc9WvAVEgPZL9NCovQTXULvOXiW1Fb7lJABZEwJyw

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.16.100.9 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.7.30.252 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 10.7.39.0 255.255.255.0 172.16.100.10

!

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

!

control-plane

!

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to

use.

-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want

to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

access-class 23 in

privilege level 15

password 123456

login

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

Please help me, i have tried in Packet Tracer for simulation. My configuration work perfectly.

Thank U very much for your attention

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Can't remote router using SSH and Telnet on cisco 1941

Remove access-class 23 from the vty lines.

Sent from Cisco Technical Support iPad App

VIP Purple

Re: Can't remote router using SSH and Telnet on cisco 1941

HI ,

Please run  these commands THEN TRY AGAGIN.

no ip http access-class 23

no access-list 23 permit 10.10.10.0 0.0.0.7


Regards

7 REPLIES

Re: Can't remote router using SSH and Telnet on cisco 1941

Remove access-class 23 from the vty lines.

Sent from Cisco Technical Support iPad App

Community Member

Re: Can't remote router using SSH and Telnet on cisco 1941

Thank you very much for your reply. I'm sorry my cisco isn't 1941 but 1921.

I have removed access-class 23 from the vty lines.

But still it can't.

Building configuration...

Current configuration : 5176 bytes

!

! Last configuration change at 02:52:30 UTC Tue Nov 5 2013 by admin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname HO-METRO-DURI

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 4 pbTc9WvAVEgPZL9NCovQTXULvOXiW1Fb7lJABZEwJyw

!

no aaa new-model

!

ip cef

!

!

!

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

!

ip domain name yourdomain.com

no ipv6 cef

multilink bundle-name authenticated

!

!

crypto pki trustpoint TP-self-signed-3627276910

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3627276910

revocation-check none

rsakeypair TP-self-signed-3627276910

!

!

crypto pki certificate chain TP-self-signed-3627276910

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33363237 32373639 3130301E 170D3133 30373139 30383535

  35375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36323732

  37363931 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81008B96 B231D09A 36DD8274 8EC98593 9DAF654D 1667C877 45AAB9BF AFFE6C51

  0EF0C859 D15B9523 0F3BC569 79CD23DA A62FBE13 1F27469C 120D701F 7FBCCE97

  B53F1E58 11B711AB 73E83ABB D4472C15 2F917C48 45D3B638 66409655 84600AC0

  57C6AB95 51A12CBA A6D53D7B B3E8FA43 69CCF25E FBBD4102 B0D295A2 A651B604

  9D6B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 144C5F0C 58E99981 359FE96E FC79ADEF 60EE3FFA 84301D06

  03551D0E 04160414 4C5F0C58 E9998135 9FE96EFC 79ADEF60 EE3FFA84 300D0609

  2A864886 F70D0101 05050003 8181004D EED4759E 30A21C3E A1E4E8B7 6F001F86

  BA3C456C F208A4CC F3A3AD98 249C6DFF BEC9305A 596CC499 B187A224 D6E74445

  E7A5C063 5C5B7D2B C7BDB4E4 B0ECA001 432985BD B7BBABE4 C7D78245 3B77EBC8

  0E402C49 54209F0F 577A826F EA46318F 293C8E17 43D49128 2A43F0DF 591551BE

  0A7BC9A6 8DEDCEE8 815E829F CCAC3A

        quit

license udi pid CISCO1921/K9 sn FGL1729248K

!

!

username admin privilege 15 secret 4 pbTc9WvAVEgPZL9NCovQTXULvOXiW1Fb7lJABZEwJyw

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 172.16.100.9 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.7.30.252 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 10.7.39.0 255.255.255.0 172.16.100.10

!

access-list 23 permit 10.10.10.0 0.0.0.7

!

!

!

control-plane

!

!

banner exec ^C

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username privilege 15 secret 0

Replace and with the username and password you want to

use.

-----------------------------------------------------------------------

^C

banner login ^C

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device.

This feature requires the one-time use of the username "cisco" with the

password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN

CREDENTIALS

Here are the Cisco IOS commands.

username   privilege 15 secret 0

no username cisco

Replace and with the username and password you want

to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE

TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the

QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp

-----------------------------------------------------------------------

^C

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

privilege level 15

password 123456

login

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

Here print screen when i try remote using ssh or telnet.

Please help...

VIP Purple

Re: Can't remote router using SSH and Telnet on cisco 1941

HI ,

Please run  these commands THEN TRY AGAGIN.

no ip http access-class 23

no access-list 23 permit 10.10.10.0 0.0.0.7


Regards

Hall of Fame Super Gold

Re: Can't remote router using SSH and Telnet on cisco 1941

My first thought when symptoms like this are described is to ask if there is IP connectivity and to suggest testing with something like ping to make sure that the PC can communicate with the router. But I see in the screenshot what appears to be the banner message from the router. So I will assume that there is good IP connectivity and we need to look for some other issue.

So my first question would be to verify whether SSH has been successfully activated on the router. Would you post the output of show ip ssh?

My second question was what kind of prompt did you receive when the connection was first established?

My third question was whether this attempt was using SSH or telnet? I would suggest that we start with telnet, since that is more simple, and worry about SSH after telnet is working?

HTH

Rick

Community Member

Re: Can't remote router using SSH and Telnet on cisco 1941

Thank u for reply,

I tried sandeepchoundhary21 suggestion and remove default user "cisco".

And it works

Thank U Jeff Van Houten, sandeepchoundhary21, Richard Burt for reply.

VIP Purple

Re: Can't remote router using SSH and Telnet on cisco 1941

If you satusfied with the answer then plz mark this question as answered.

Thanks
Please rate helpful post

Sent from Cisco Technical Support iPhone App

Community Member

to remotely access a router,

to remotely access a router, after telnet which ip address should be given? default or the ip address of the router? if default is not given then what is the use of default gateway?

11521
Views
4
Helpful
7
Replies
CreatePlease to create content