Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

Cisco 831 Router w/ ISP Static IP Internet Problem

Hey guys - Just wanted to say you do a great job responding to this forum. I have an issue that I could use some help with. I have a Cisco 831 router connected to a DSL router provided by my ISP with 5 static ip addresses. All I want to do is provide Internet connectivity with this 831 router to some office staff but I can't get it to work when I statically map an IP address to the Ethernet1 interface. The Internet only works when I set Ethernet1 to DHCP from the DSL router. But, I don't want to do that because I need the other 4 static addresses for something else and I don't want the 831 to use the ones in use.

Here is the config:

!

version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ******

!

enable password 7 0215575819551B2A1F57

!

no aaa new-model

ip subnet-zero

ip name-server XXX.XXX.101.201

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool CLIENT

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server XXX.XXX.101.201

lease 0 2

!

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

!

interface Ethernet1

ip address XXX.XXX.101.205 255.255.255.248

ip nat outside

duplex auto

no cdp enable

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

ip nat pool mypool XXX.XXX.101.205 XXX.XXX.101.205 netmask 255.255.255.248

ip nat inside source list 102 interface Ethernet1 overload

ip classless

ip http server

no ip http secure-server

!

access-list 23 permit 10.10.10.0 0.0.0.255

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

!

line con 0

exec-timeout 120 0

password 7 011E2616500E121C28584B590916

login

no modem enable

stopbits 1

line aux 0

line vty 0 4

access-class 23 in

exec-timeout 120 0

login local

length 0

!

scheduler max-task-time 5000

!

end

XXX.XXX.101.201 is the IP address of the DSL router. I want to use XXX.XXX.101.205 as the IP address for Ethernet1. When it works under DHCP, here is the portion of the config:

interface Ethernet1

ip address dhcp client-id Ethernet1

ip nat outside

duplex auto

no cdp enable

What I did was to static map all of the parameters I received from when The Ethernet1 interface was to DHCP to the current config. But, it doesn't work when running an Internet browser. I even did a nslookup when it was statically mapped, and I received answers when querying XXX.XXX.101.201. But, when I attempt to surf, it doesn't work. When I try to ping www.whatever.com at the client machine, I receive Destination host unreachable. Do you guys have any ideas? THANKS!

  • Remote Access
2 REPLIES

Re: Cisco 831 Router w/ ISP Static IP Internet Problem

hi

Do u know how the SP is mapping the static ips to you ?

There should be a static route (reverse route) for the static ips being provided by the SP towards your ip which you are getting randomly from DHCP.

In this case i dont think mapping at the SP end is possible..

Also your nat pool which you configured doesnt seem to be used anywhere and at the first place it has to be corrected..

Again i c that you are using PAT using overload then theres no need to define a pool out there like that and make use of that.

Also clarify where you gonna map the other static ips and are you trying to map them to inside local lan ips ??

regds

New Member

Re: Cisco 831 Router w/ ISP Static IP Internet Problem

I am new to configing cisco routers, so I am not sure if there is any problem w/ your config. I wanted to chime in and say that sometimes when ISP's give you a static IP address, you still have to get it via DHCP. They map your pool of static addresses to the mac address of your cable/dsl modem. Then you set your client router or pc's to dhcp and it gives an IP address out of that pool. I set up a small company on Cox High Speed Cable. The same thing happened to me. They assigned me a static IP address, but I was not able to put in the static address on the external interface. I had to set the interface to DHCP. When I set it to DHCP, I got the correct address. I called them and they verified, that it was static DHCP done by MAC address. Hope this helps.

485
Views
0
Helpful
2
Replies