Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CISCO 837 ADSL Configuration

Please check the configs below for ADSL connectivity for CISCO 837, I am trying for several days but unable to get through it.

Router#show running-config

Building configuration...

Current configuration : 1957 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

ip name-server 213.42.20.20

ip name-server 195.229.241.222

ip audit notify log

ip audit po max-events 100

ip ssh break-string

vpdn enable

!

no ftp-server write-enable

no scripting tcl init

no scripting tcl encdir

!

!

!

no crypto isakmp enable

!

!

!

!

interface Ethernet0

ip address x.x.x.x x.x.x.x

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

pppoe enable group global

pppoe-client dial-pool-number 1

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/50

pppoe-client dial-pool-number 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxxxx

ppp chap password 0 xxxxxx

ppp pap sent-username xxxxxx password 0 xxxxxx

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

!

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

password cisco1

login

no modem enable

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

password cisco1

login

transport preferred all

transport input all

transport output all

!

scheduler max-task-time 5000

!

end

Router#

Router#

6 REPLIES
Hall of Fame Super Gold

Re: CISCO 837 ADSL Configuration

Does the circuit sync in first place? Check "show dsl interface".

Community Member

Re: CISCO 837 ADSL Configuration

Yes, it does.

Community Member

Re: CISCO 837 ADSL Configuration

hi,

please look in to the dialer config,

interface Dialer1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 2

dialer-group 2

no cdp enable

ppp authentication pap callin

ppp pap sent-username XXXxx password xxxxxx

dont enable chap use only Pap as mentioned above

Community Member

Re: CISCO 837 ADSL Configuration

doesn't work.

Hall of Fame Super Gold

Re: CISCO 837 ADSL Configuration

You show not give one-line answers and bring more info instead.

To begin with, send revised config, show dsl interface, debug ppp negotiation.

Community Member

Re: CISCO 837 ADSL Configuration

Try adding the following

!

vpdn-group global

request-dialin

protocol pppoe

!

... and be aware of your MTU settings, I am not sure of your ISP but usually is as follows.

!

interface Dialer0

mtu 1492

!

and the physical eth will be...

!

interface Ethernet0

ip tcp adjust-mss 1452

!

Regards

1108
Views
0
Helpful
6
Replies
CreatePlease to create content