Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 837 not connecting to BT ADSL

Hi.

I am new to the Cisco 837, and trying to set it up to connect with BT ADSL.

Has anyone tried this before? What do I need to do to get it working? I tried everything I can so far, but no luck :-(

David.

25 REPLIES
Silver

Re: Cisco 837 not connecting to BT ADSL

Hello David,

You can try the following configuration to get you started:

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0

no ip address

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

dsl operating-mode etsi

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname myUsername@btbroadband.com

ppp chap password myPassword

ppp pap sent-username myUsername@btbroadband.com password myPassword

ppp ipcp dns request

ppp ipcp wins request

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source list 102 interface Dialer1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

dialer-list 1 protocol ip permit

See BT Broadband Support website

http://btbroadband.custhelp.com/cgi-bin/btbroadband.cfg/php/enduser/cci/btb_adp.php?p_sid=4n77yBai&p_faqid=644

HTH

--Leon

* Please rate posts.

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi Leon.

Thanks, as I am new to this router, how do i enter the values?

Through SDM, CWRS or console?

David.

Silver

Re: Cisco 837 not connecting to BT ADSL

Hello David,

You can by using the console. Paste your configuration after the "Router(config)#" prompt.

Router>enable

Router#configure terminal

Router(config)#

Alternatevely you can setup your router throug SDM, using the information provided by BT and the accompanied document in my previous post.

Good luck!

--Leon

* Please rate posts.

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

I have already been trying via sdm, but i always get the same results "page not found".

I have just tried your config file with some adjustments for my details, but I saw that fail for 2 lines:

dsl operating-mode etsi

this line failed with a arrow pointing to the e of etsi

and

ppp pap sent-username myUsername@btbroadband.com password myPassword

this failed with an arrow pointing to the p of password, or in my case the first char of my pwd.

of course I change the line above to my adsl uid and pwds.

David.

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

Do I type that list of settings in somewhere? Or import them?

David.

Silver

Re: Cisco 837 not connecting to BT ADSL

Hello David,

The config below will work with BT Broadband.

All you will need to do is ensure that you

change the DNS server addresses and use the correct ppp username and

password.

There is no documentation regarding

assistance with configuration guidelines to PPPoA in the UK.

!This is the running config

!--------------------------------------------------------------------------?--

!version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname gateway

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret

!

username Cisco privilege 15 secret

clock timezone PCTime 0

clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00

no aaa new-model

ip subnet-zero

no ip source-route

ip domain name

ip name-server 192.168.0.1

ip name-server 212.159.13.49

ip dhcp excluded-address 192.168.0.1

!

ip dhcp pool sdm-pool1

import all

network 192.168.0.0 255.255.255.0

dns-server 212.159.6.9 212.159.13.49

default-router 192.168.0.1

!

!

no ip bootp server

ip audit notify log

ip audit po max-events 100

ip ssh break-string

no ftp-server write-enable

!

!

!

no crypto isakmp enable

!

!

!

!

interface Ethernet0

description $FW_INSIDE$$ETH-LAN$$INTF-INFO-Ethernet 10/100$

ip address 192.168.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip tcp adjust-mss 1452

no cdp enable

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname

ppp chap password 0

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

!

!

access-list 1 remark INSIDE_IF=Ethernet0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run

!

control-plane

!

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

no modem enable

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

privilege level 15

login local

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

!

end

Best of luck!

--Leon

* Please rate posts.

New Member

Re: Cisco 837 not connecting to BT ADSL

Thanks for that, however it still does not work.

The CD light is on, but when I try to browse the web it says page cannot be found etc.

Do you know how I can clear the code/settings from memory? The could that I copy into configure terminal etc.

David.

New Member

Re: Cisco 837 not connecting to BT ADSL

ahhhh, not sure why, but i can no longer access the router via sdm. Cannot find the ip address???

erm.....help

Silver

Re: Cisco 837 not connecting to BT ADSL

David,

Do the following:

Connect to the router using console.

Router>enable

Router#erase startup-config

Router#reload

The startup-config has been removed from NVRAM. Now paste the previous posted configuration into the router.

To access the SDM type the IP address used in the configuration. Check to see if your PC has an IP address assigned to it that matches the IP subnet configured on the router.

Good luck!

--Leon

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

I have followed your instructions, erased the startup, load on yoru last config after changing DNS and chap uid and pwd. However this has not worked.

- On the console it now prompts me for as uid and pwd that I dont know, and now cannot access the console.

- when i try to renew and check my ip address, i get a message saying that the router could not find the DNS server.

When I ran your script, I noticed that there were some other usernames and passwords. But also noticed some errors, see as follows:

gateway(config)#ip domain name ^

% Invalid input detected at '^' marker.

pointing to the d of domainname

gateway(config)#ip ssh break-string

^

% Invalid input detected at '^' marker.

pointing to the B of break-string

gateway(config-line)#login local

% Invalid input detected at '^' marker.

could not see what this was pointing to?

gateway(config-line)#transport preferred all

^

% Invalid input detected at '^' marker.

pointing to the a of all

I also noticed other usernames and passwords, but not sure if i should have changed those.

Any ideas?

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

Think I just fixed the uid and pwd problem, by using the "confreg 0x2142" idea found on the www. Its got me back in, but not a clue if it messed anything else up, as I dont have a clue ;-)

Really worried why I cannot get this router to work, but DSL-504T made it so easy ;-)

is there a why I can see if certain bits have worked, so can I check if the router actually connected with ADSL? I am wondering where the problem actually is.

David.

New Member

Re: Cisco 837 not connecting to BT ADSL

Futher to my last I have just foudn that I get the following after running your script:

Windows IP Configuration

An error occurred while renewing interface Local Area Connection 2 : unable to c

ontact your DHCP server. Request has timed out.

No operation can be performed on Local Area Connection 3 while it has its media

disconnected.

Also I can no long connect to the unti via SDM, but then again, I sont know what IP addderss its using now?

David.

Silver

Re: Cisco 837 not connecting to BT ADSL

David,

Look at your router is the interface that connects your PC lit?

When connected to the console issue the command "sh ip interface brief", look at the port connected to your PC. Is both the line protocol as the link status "UP"?

Check the status of the DHCP server, as configured. Issue the command "sh ip dhcp server statistics".

When your LAN interface is up once again, and you have an address assigned you can enter SDM via the IP address 192.168.0.1.

--Leon

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

thanks once again.

problem is that when i run your config, I cannot login to the router, so cannot run your suggestions.

Do you know what username and password is required after the config is installed?

David.

Silver

Re: Cisco 837 not connecting to BT ADSL

David,

I assumed that you'd replace the enable secret with your password. See line "enable secret " in the configuration.

As passwords cannot contain spaces, the password should be "

In case this fails you can recover the password. See the detailed instructions on Cisco.com.

http://www.cisco.com/warp/public/474/pswdrec_827.shtml

Live will be much easier with SDM ;-)

Good luck!

--Leon

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

Ok, i reload the router, and re-worked the config you sent me, so now have everything in place.

However, the PC cannot aquire an IP address from the router?

David.

New Member

Re: Cisco 837 not connecting to BT ADSL

I presume the router IP should be 192.168.0.1?

David.

Re: Cisco 837 not connecting to BT ADSL

Hello,

sorry for dropping in, but you might want to try:

dsl operating-mode ansi-dmt

There is an issue with BT and Cisco 837 routers that require the mode to be ansi-dmt...

HTH,

GNT

Silver

Re: Cisco 837 not connecting to BT ADSL

David,

Follow the following troubleshooting methodology:

- Is the physical connection in place?

- Is the interface connected to your PC "up", issue "show interfaces brief" on the command line to check the status. If the interface is administratively disabled you can enabled it by entering "conf t", followed by "interface Fa0/N" where N represents the port number. Issue "no shutdown" on the (config-if) prompt.

- Does either NIC or switchport has the LINK led lit?

- Does either NIC or switchport has a blinking ACT led?

- On your PC enter "ipconfig /all". Does it have an IP address assigned in the range 192.168.0.0/24?

- Ping the router from the PC, is it reachable?

- Open webbrowser to start SDM.

Evaluate if you need the configuration hint mentioned in the previous post.

Good luck!

--Leon

New Member

Re: Cisco 837 not connecting to BT ADSL

Good idea, as the issue now has changed of course.

Here are my issues now

- Cannot connect to router via iexplorer. Cannot connect with or to SDM.

- PC could not view web pages via the router after being configured.

Answers to your questions:

- Yes. The ADSL is up and tested via another (dlink) router.

- Status says "up" for Ethernet0 and FastEthernet1 (my cable is in that port), but no ip is assigned

- both PC and router have the link light lit

- cannot see any lights blinking for this, but will describe lights last

- No. "Autoconfiguration IP Address. . . : 169.254.46.240", and "Subnet Mask . . . . . . . . . . . : 255.255.0.0"

- No.

- Does not work either via web or via SDM App.

Lights seen:

Router

------

Ok, steady green

ADSL CD, steady green. When ADSL not plugged in, this goes out and ADSL RXD/TXD flash like crazy.

ADSL RXD, off

ADSL TXD, off

1, Steady On

2, Off

3, Off

4, Off

RXD, Off, Sometimes flashes or flickers

TXD, Off, Sometimes flashes or flickers

NIC

---

Steady green and another that flashes with traffic.

Hope that helps.

New Member

Re: Cisco 837 not connecting to BT ADSL

Further details, these are the settings that BT ADSL are requesting:

DNS = auto

VPI = 0 (zero)

VCI = 38

Authentication = CHAP

Modulation = G.DMT

Encapsulation = VC MUX

Encapsulation Protocol = PPPoA, whether USB modem or Ethernet router

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi.

Ok, so now lets start again, as I have got things back to normal - PHEW!

So now I how the correct IP address, and I can access SDM.

BUT - My original and old problem.

When I try to view a webpage, I get "page not found" etc.

By doing "sh int atm0", I think can see that the ADSL appears to have a connection. I also also done "ping atm interface...", and that is also successful.

Any ideas from here?

David.

New Member

Re: Cisco 837 not connecting to BT ADSL

YESSSS

Finally got it working, the final problem turned out to be a simple DNS error. So sourced different DNS servers.

Thanks very much for your help and patience!

David.

Silver

Re: Cisco 837 not connecting to BT ADSL

Thanks for the complete picture.

It's obvious you can't connect to SDM because of the IP address mismatch.

The Autoconfiguration IP Address (APIPA) address is assigned when a DHCP request times out.

Please issue "debug ip dhcp server" at the console of the router. This will display the IP configuration negotiation between your PC and router.

Router# debug ip dhcp server events

Router# debug ip dhcp server packets

DHCPD:DHCPDISCOVER received from client 0b07.1134.a029 through relay 10.1.0.253.

DHCPD:assigned IP address 10.1.0.3 to client 0b07.1134.a029.

DHCPD:Sending DHCPOFFER to client 0b07.1134.a029 (10.1.0.3).

DHCPD:unicasting BOOTREPLY for client 0b07.1134.a029 to relay 10.1.0.253.

DHCPD:DHCPREQUEST received from client 0b07.1134.a029.

DHCPD:Sending DHCPACK to client 0b07.1134.a029 (10.1.0.3).

DHCPD:unicasting BOOTREPLY for client 0b07.1134.a029 to relay 10.1.0.253.

DHCPD:checking for expired leases.

Also use "show ip dhcp server statistics" to see if the router receives DHCPDISCOVER broadcasts from your PC.

Good luck!

--Leon

New Member

Re: Cisco 837 not connecting to BT ADSL

Hi Leon.

Thanks for your help with all this, however please see my last entry as its all now working fine.

I ended up resetting the router, and manually typing in some config. This then enabled SDM to work, and was then back to my original problem.

My original problem was then fixed by supplying the correct DNS server addresses.

Thanks for your help once again, and sorry that this one was so hard work. I know I am new to all this, but really appreciate you time and effort.

THANKS! :-)

David.

667
Views
0
Helpful
25
Replies
CreatePlease login to create content