Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 871 as PPPoE server

Hi All,

I can't configure 871 as PPPoE server. Small part of config:

interface Loopback1

ip address 192.168.102.1 255.255.255.0

!

bba-group pppoe PPPoEGroupBBA

virtual-template 2

sessions auto cleanup

!

interface FastEthernet3

pppoe enable group PPPoEGroupBBA

!

interface Virtual-Template2

ip unnumbered Loopback1

ip nat inside

ip virtual-reassembly

peer default ip address pool PPPOEpool

ppp authentication ms-chap-v2 chap callin Radius

ppp authorization Radius

ppp accounting Radius

!

ip local pool PPPOEpool 192.168.102.10 192.168.102.250

But router with this configuration doesn't send PADO. In logs (debug pppoe elogs|errors|events|packets) also doesn't write any messages. From PC I see PADI packet, but not PADO. Also tried "pppoe enable" on vlan1 interface with same result.

What is wrong? Or this router can't work as PPPoE server?

Also this router act as PPPoE client and PPTP server and vlan1 in bridging mode with WLAN, maybe this is problem?

2 REPLIES
New Member

Re: Cisco 871 as PPPoE server

This is a small router for SOHO.

And I see that it's enable to FastEthernet interface. To which equipment this interface is connected ?

Regards,

Omar

New Member

Re: Cisco 871 as PPPoE server

Thanks for your reply,

Interface connected directly to PC. I'm newbie in cisco... May be I must connect PC to L2 switch and then to 871, and interface must be in trunk mode (now it in access mode)?

My 871 has IOS 12.4(15)T1 and feature set: Advanced IP Services. Feature navigator shows, that it suports:

PPPoE Client

PPPoE Client DDR Idle-Timer

PPPoE MTU Adjustment

PPPoE on Ethernet

PPPoE Radius Port Identification

PPPoE Relay

PPPoE Server Restructuring and PPPoE Profiles

PPPoE Session limit

PPPoE Session Limit per NAS port

So I believe that it can act as PPPoE server.

In old configuration FastInterface3 was on vlan1. And it in bridge mode with WLAN.

When I change configuration so:

interface FastEthernet3

switchport access vlan3

!

interface vlan3

ip address 10.0.0.1 255.255.255.0

pppoe enable group PPPoEGroupBBA

Router begin receive PADI packets and write in log:

PPPoE 0:I PADI R:00b0.c2e9.c470 L:ffff.ffff.ffff vl3

PPPoE 0:I PADI R:00b0.c2e9.c470 L:ffff.ffff.ffff vl3

PPPoE 0:I PADI R:00b0.c2e9.c470 L:ffff.ffff.ffff vl3

PPPoE 0:I PADI R:00b0.c2e9.c470 L:ffff.ffff.ffff vl3

Then connection fails by timeout. Why it doesn't send PADO?

And when I set "pppoe enable group PPPoEGroupBBA" on FastEthernet instead of vlan, then router doesn't receive PADI packets (doesn't write them to log).

853
Views
0
Helpful
2
Replies