Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 876W Router - Wireless Comms Problem

I have the following physical sratus...

PC -> Wireless Card -> Router 876W (192.168.100.1)-> Sitch -> AccessPoint -> ....wireless..... -> Access Point -> Modem/Router (192.168.0.1) -> ADSL Line

On this configuration with the above IPs i have create a VLan on 876W with IP 192.168.100.1 and the some subnet has my PC 192.168.100.2.

When i am connectin to the router through a cable on Port 1 (on posrt 0 is plugged in the Switch with the Wirelless Access Point) everythink is ok and the router is routing any packet to the other network (192.168.0.1). So by asking http://192.168.100.1 from my pc i been redirect to http://192.168.0.1 and everyone is huppy.

Now i want to have the some routing when i am connecting through my PCI Wireless Card. But instead of this the only think i can see through wireless card is the router at 192.168.100.1. How can i make the router to route any packets it gets on dot1q interface to port 0, so to be able to see 192.168.0.1?

Actually i want to connect on router two user wireless and one user with cable.

Pls could somebody help me??? I am new on networking... and i am little confused...

I am sending the current config of router

7 REPLIES
VIP Purple

Re: Cisco 876W Router - Wireless Comms Problem

Hello,

looking at your configuration, I am thinking that maybe there is a spanning tree loop between the VLAN 1 on your router, and the (default) VLAN 1 on the switch. Can you try and disable spanning-tree on your VLAN 1 interface of the router:

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$

no ip address

ip nat allow-static-host

bridge-group 1

bridge-group 1 spanning-disabled

Also, if that doesn't help, can you try an d configure a different VLAN, e.g. VLAN 2, for the wireless clients ? That would mean adding the following to your router configuration:

interface Dot11Radio0.2

encapsulation dot1Q 2

no cdp enable

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 spanning-disabled

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

!

interface Vlan2

no ip address

bridge-group 2

bridge-group 2 spanning-disabled

!

interface BVI2

ip address 192.168.2.1 255.255.255.0

!

bridge 2 route ip

Then, assign an IP address in the range 192.168.2.0/24 to your clients, or use DHCP:

ip dhcp pool vlan2

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

Can you try this and see if it makes a difference ?

Regards,

GP

New Member

Re: Cisco 876W Router - Wireless Comms Problem

Hi Georg,

Thanks fro your time, but did not work...

I was reading your discusion with Athol... and i think i may have the some problem...

Besides that i made some changes, you will see them in config file...

I have to give the physical status of Switch Potrs on router.

Port 0: Is connected with a fast ethernet switch of DLink (does it make any diference???)

Port 1: Network Cable connected on my on board LAN Card

Port 2: Is connected with a fast ethernet switch of DLink (does it make any diference???) - actually when i am connecting through cable i use Port 2 with IP (192.168.100.1) and everythink is ok... and when i use the wireless Card (DLink too) of my PC, with IP 192.168.2.1 it does nothing...

Somehow yet, i am not sure how, i deleted BVI1... but it seems to be no problem because i can browse everywhere...

Do i have to set trunk mode?

Kind Regards

Antonis

VIP Purple

Re: Cisco 876W Router - Wireless Comms Problem

Hello Antonis,

I just suggested to Athol to configure the interface where the switch is connected to as following:

interface FastEthernet0

switchport trunk encapsulation dot1q

switchport mode trunk

I am wondering if the interconnection between your (D-Link) switch (and Athol´s Intel switch) might not be working properly...

Can you try that config and see if you can establish connectivity ?

Regards,

GP

New Member

Re: Cisco 876W Router - Wireless Comms Problem

Hi Georg,

As you saw in the config file the following configuration didn't work..

interface FastEthernet0

switchport access vlan 2

switchport trunk native vlan 2

no ip address

no cdp enable

I tried this one too... niether this worked...

interface FastEthernet0

switchport access vlan 2

switchport trunk native vlan 2

switchport mode trunk

no ip address

no cdp enable

i couldn't set this command 'switchport trunk encapsulation dot1q'...

while i executed this command for some reason the router couldn't set it on FastEthernet Interface instead of that the encapsulation there is on

interface Dot11Radio0.2

encapsulation dot1Q 2

...

How am i suppoce to set this command on FastEthernet nterface, could you send me the command line?

Is this configuration ok !!!???

interface FastEthernet0

switchport access vlan 2

switchport trunk native vlan 2

What is mean 'native' vlan 2?

Why it has both access and trunk mode enabled on interface?

Keep in mind, too, that when i am connecting through cable, on Router's port 1 (counting from 0) is connected the cable to my PL Lan card (OnBorad Card not the wireless one), and on Router's port 2 is connected the D-Link switch... Why is this configuration working perfectly???? (I think i will take a cold bath!!!!)

Somewhere i read something about VLAN Tagging!!! I do not what is this exactly, and i do not remember where i had read it... i will search it... Could this be relative to our problem?

Regards

Antonis

VIP Purple

Re: Cisco 876W Router - Wireless Comms Problem

Hello Antonis,

I think there should not be more than this on the interface:

interface FastEthernet0

switchport mode trunk

This configuration will make sure that all VLANs coming in on the trunk will be accessible. Can you try and take out the other commands:

no switchport access vlan 2

no switchport trunk native vlan 2

and just put this one in:

switchport mode trunk

Regards,

GP

New Member

Re: Cisco 876W Router - Wireless Comms Problem

i will try this later today, because i am not at home write now... and i will let you know about...

Thank you...

Antonis

New Member

Re: Cisco 876W Router - Wireless Comms Problem

Hi GEORG,

Unfortunately, nothing. Its like to ignore totaly the BVI2 and the FastEthernet Configuration. Write now i have connect the Access Point (D-Link!!!) on router's port 0 and i can browse using the IP 192.168.100.2... I can see the Access Point on 192.168.0.50 (differnet netwroks .100.2 --- .0.50) actually the router does the routing as it should be.

But when i am connecting using PC Wireless Card i can see NOTHING, not only i can not browse, but i can not either see the Access Point on IP 192.168.0.50 !!!!! ( I have tried to plug the AP on FastEthernet 0 as it is now... and on FastEthernet 2...)

I think that the router, for some reason, just dissapears the packects it gets on its antennas, without routing them to the FastEthernet 0 and then to AccessPoint.... something that it does when i am using the cable connection even yet on FastEthernet 0 Port, that is supposed we have configured for Trunk and for the IP 192.168.2.1 !!!!! ...

How can i see where the packects travell around?

Could be some bug of the IOS (version 12.3 (8)Y12)?

Could be the D-Link AccessPoint... but it works fine with the cable connection????

I am sending you the last configuration...

Please, any good idea...!!!

regards

Antonis

301
Views
0
Helpful
7
Replies
CreatePlease to create content