Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 877 Router

Where can I get a basic config for a 877 ADSL router? The problem is that we have router at a customer site which needs uesed my our onsite engineers to make a connection into the customer's network, connect to the internet and vpn into our network. I have been able to get the ADSL router to see the customer's router but anything behind the ADSL router is not able to access the customer's router.

extract from config:

--------------------

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.18.46.1 172.18.46.128

!

ip dhcp pool cust-brad-test

import all

network 172.18.46.0 255.255.255.0

domain-name domain.name.com

dns-server 172.18.18.65 172.18.16.65

default-router 172.18.46.1

netbios-name-server 172.18.18.65 172.18.16.65

!

!

interface FastEthernet0

no shut

!

interface FastEthernet1

switchport access vlan 2

no shut

!

interface FastEthernet2

switchport access vlan 2

no shut

!

!

interface Vlan1

no description

ip address 172.20.96.3 255.255.255.248

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1452

no shut

!

interface Vlan2

no ip address

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

no shut

!

!

interface BVI1

ip address 172.18.46.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

no shut

!

Vlan 1 is going to cust. Vlan 2 is into the DHCP provided by ADSL. Right now I am trying to get this connection working 1st ....about to pull my hair out!!!

Please help ... SOS

3 REPLIES
Bronze

Re: Cisco 877 Router

I've configured a bunch of 837 routers for ADSL, the concepts should be the same for an 877. Basically you need to create a Dialer interface that does the actual ADSL "trainup" and apply that dialer profile to the ATM (ADSL) interface on the router. You do not need to create a vlan for the ADSL network, only for internal networks. I've found that each provider has a slightly different way to connect into their network, so you're going to have to tweak.

Search the Cisco site for "dsl router configuration guide", you'll find a lot of good information. I think your problem might be with the way you're configuring your 'outside' ADSL interface, the internal VLAN, and how you're routing between the two.

Post your full config and an explanation of what routes/networks are where (maybe post a 'show ip route')

New Member

Re: Cisco 877 Router

- WHAT I NEED TO DO:

--------------------

1. Connect 172.18.44.X to the customer network 172.20.96.X. The ip route statement has been added onto the 877. I can ping 172.20.96.2 (Customer Router) from the 877 but not from any of the 172.18.44.X addresses. Should the ip route statement take care of this or should there be another NAT statement somewhere

2. I need to access servers on my CO internal network - 172.18.18.X , 172.18.16.X

3. ADSL internet access is not a problem. That works fine.

Re: Cisco 877 Router

Hello,

I am not clear on your network setup. Can you post a drawing with all links involved ?

Regards,

GNT

269
Views
0
Helpful
3
Replies
CreatePlease to create content