Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco AnyConnect and Linux

I am trying to access a cisco vpn site with my computer running linux (fedora 16).  If I go the the vpn gateway site I can either run the AnyConnect client 2.5  software from online or download and install it.  After I try to connect to the gateway I get this message:

AnyConnect cannot confirm it is connected to your secure gateway.  The local network may not be trustworthy.  Please try another network.

I have added the gateway website as an exception in firefox and when I try to navigate to the site with firefox I get a certificate warning, and if I disregard the warning and continue to the gateway I can then get to where anyconnect will load from online, but when I actually try to connect I get the message above.

My computer is a laptop and if I remove the drive with linux on it and replace it with one with windows on it and add the gateway to exceptions in internet explorer I again am prompted that there is a problem with the certificate, but, if I choose to continue and ignore the warning I can then connect.

I'd rather stay in linux rather than switch out hard drives.

Any suggestions?

Everyone's tags (3)
2 REPLIES
Cisco Employee

Cisco AnyConnect and Linux

Sounds like Linux needs the certificate installed before allowing access. Try to install the certificate in your trusted root certificate store and try to connect again.

Community Member

Cisco AnyConnect and Linux

I don't know what or where the certicate store is.

I copied the pem file for the site to: /opt/.cisco/certificates/ca, but I still get the error.

I've also done:

[root@localhost /]# mkdir /root/certs

[root@localhost /]# cp /home/tmort/Downloads/gd-class2-root.crt /root/certs

[root@localhost /]# cp /home/tmort/Downloads/gd_intermediate.crt /root/certs

I also followed some other instructions and copied the above files somewhere else, but, I still get the error

Can you elaborate?

3697
Views
0
Helpful
2
Replies
CreatePlease to create content