Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco ASA5505 Remote Access with VPN Client

I have setup several of these before but i am baffled. I have followed some of the other posts here and tried alot of options but still cannot figure this out.

I installed a new ASA5505 and configured it using the wizards and have the initial configs working just fine. I also ran through the Wizard on Remote access for IPSEC clients and am using the Cisco VPN client on windows 7 but I cannot map any drives nor see the internal network. I'm able to connect to the VPN so that part is working but I can't go further.

Result of the command: "show run"

: Saved
:
ASA Version 8.2(5)
!
....

interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.2 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 55.55.55.55 255.255.255.248
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name myco.local

...

access-list XXXVPNgroup_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.0.208 255.255.255.240
access-list inside_access_in extended permit tcp 192.168.0.0 255.255.255.0 any eq telnet
access-list inside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
ip local pool VPNRange 192.168.0.210-192.168.0.219 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
....
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 50.240.158.62 128
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp inside
....
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.0.210-192.168.0.219 inside
dhcpd dns 208.67.222.222 208.67.220.220 interface inside
dhcpd lease 86400 interface inside
dhcpd domain prinet.local interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
group-policy XXXVPNgroup internal
group-policy XXXVPNgroup attributes
wins-server value 192.168.0.6
dns-server value 192.168.0.7 192.168.0.6
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value XXXVPNgroup_splitTunnelAcl
default-domain value prinet.local
username ben password X encrypted privilege 0
username ben attributes
vpn-group-policy XXXVPNgroup
tunnel-group XXXVPNgroup type remote-access
tunnel-group XXXVPNgroup general-attributes
address-pool VPNRange
default-group-policy XXXVPNgroup
tunnel-group XXXVPNgroup ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context

I can net use and telnet at every other location I've done but cannot here so I wonder if I've setup something wrong and, if not, perhaps there is something I can do to monitor the traffic that should be coming back but isn't.

Much appreciated!    

3 REPLIES
Silver

Cisco ASA5505 Remote Access with VPN Client

Hi,

when the vpn client connects, what ip address is it getting?  It seems you config is missing the following command:

vpn-addr-assign local

regards

John

Hall of Fame Super Gold

Cisco ASA5505 Remote Access with VPN Client

Wrong forum, post in "Security - VPN". You can move your posting with the Actions panel on the right.

New Member

Cisco ASA5505 Remote Access with VPN Client

Hi,

Please enter the following command:

crypto isakmp nat-traversal 30 then try to conect again, if you still have issues we will need to follow some TS steps

Regards,

715
Views
0
Helpful
3
Replies
CreatePlease to create content