Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco router as PPTP client

Hi,

is it possible to use a Cisco router as a PPTP client?

The problem: To get a fixed IP from an ISP in Asia we need to dial in via PPTP. The fixed IP gets assigned at the PPTP interface. Actually we have a PC connected and it works. I want now to replace the PC with a router.

Sample configs are welcome.

Regards

Markus

2 REPLIES
Silver

Re: Cisco router as PPTP client

PPTP was initially supported in Cisco IOS Software Release 12.0(5)XE5 on the Cisco 7100/7200 routers. It then moved to Cisco IOS general platform support in Cisco IOS Software Release 12.1(5)T.

http://www.cisco.com/en/US/products/sw/secursw/ps2086/products_configuration_example09186a008009436a.shtml#pre

Community Member

(router to pptp server)



(router to pptp server):
interface gig 0/0/0
ip address 10.96.174.225 255.255.254.0
no sh

(router to pc):
interface Gig 0/1
ip nat inside
ip address 172.21.2.1 255.255.255.0
no sh

(Pc):
172.21.2.2
255.255.255.0
172.21.2.1
------------------------------------------------------

Router :

service internal
vpdn enable

vpdn-group 1
request-dialin
protocol pptp
pool-member 1
initiate-to ip 31.24.238.222
ex

interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer persistent
ppp chap hostname pptphostname
ppp chap password 0 pptppassword
ip nat outside
ex

ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 31.24.238.222 255.255.255.255 10.96.174.1

dialer-list 1 protocol ip permit
ip nat inside source list 100 interface dialer 0 overload
access-list 100 permit ip any any

519
Views
0
Helpful
2
Replies
CreatePlease to create content