Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Configuring PPPoE on 2801 with WIC-1ADSl

Hello All!

I try to configure 2801 with WIC-1ADSl

part of my config is:

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/55

encapsulation aal5mux ppp dialer

pppoe-client dial-pool-number 1

!

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

show int dialer

but in this configuration i cann't connect to ISP (and recive ip address)

show int Dialer 1

Dialer1 is up, line protocol is up (spoofing)

Bound to:

Virtual-Access2 is up, line protocol is down

yourname#debug dialer packets

Dial on demand packets debugging is on

yourname#ping 195.161.136.2

Sending 5, 100-byte ICMP Echos to 195.161.136.2, timeout is 2 seconds:

*Mar 15 12:37:33.523: Di1 DDR: ip (s=192.168.0.230, d=195.161.136.2), 100 bytes,

outgoing interesting (ip PERMIT)

*Mar 15 12:37:33.523: Di1 DDR: Cannot place call, no dialer string set.

*Mar 15 12:37:35.523: Di1 DDR: ip (s=192.168.0.230, d=195.161.136.2), 100 bytes,

outgoing interesting (ip PERMIT)

Can anybody help me to correct problem?

Thank you very much

5 REPLIES
Bronze

Re: Configuring PPPoE on 2801 with WIC-1ADSl

Hello,

try and change the ppp authentication to:

ppp authentication pap chap callin

in order for the router to try and authenticate with PAP first.

In addition, you might want to try and add:

dialer-list 1 protocol ip permit

to your configuration.

Also, typically, when connecting to an ISP, you would implement NAT. Do you have public IP addresses assigned to yuor internal network ? If not, try and make the following changes:

interface FastEthernet0/0

ip address x.x.x.x y.y.y.y

ip nat inside

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/55

encapsulation aal5mux ppp dialer

pppoe-client dial-pool-number 1

!

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

-->ip nat outside

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

Regards,

Nethelper

Re: Configuring PPPoE on 2801 with WIC-1ADSl

Tnank you very much!!!

the first part of my task is solved...

now my config is

yourname#show run

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

ip domain name yourdomain.com

vpdn enable

vpdn ip udp ignore checksum

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.0.230 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

interface ATM0/1/0.1 point-to-point

pvc 0/55

oam-pvc manage

pppoe-client dial-pool-number 1

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 2

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

But I need to configure second chanel with PPPoEoA (ethernet over ATM or encapsulation MAC or Enet encap)encapsulation for access to inside SP network (172.16.x.x etc.)

How I can do this?

Bronze

Re: Configuring PPPoE on 2801 with WIC-1ADSl

Hello,

I am not clear on what you are looking for. Who is your ISP, and what are you trying to accomplish, that is, what do you mean by ´access to inside SP network´?

Regards,

Nethelper

Re: Configuring PPPoE on 2801 with WIC-1ADSl

I need to create 2 channel:

1. PPPoE Authenticated channel to public Internet...

2.UnAuthenticated channel to private SP network

for this network SP use pvi/vci 0/33

and "encapsulation protocol" that It called

"Enet Encap"

this is Zyxel feature, and I don't now what is it in Cisco terminology... but suspect what is PPPoEoA

and I Try to find this solution on Cisco system...

Re: Configuring PPPoE on 2801 with WIC-1ADSl

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/1/0.1 point-to-point

pvc 0/55

oam-pvc manage

pppoe-client dial-pool-number 1

!

!

interface ATM0/1/0.2 point-to-point

ip address 192.168.30.100 255.255.255.0

atm route-bridged ip

pvc 0/33

oam-pvc manage

!

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 2

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 192.168.1.0 255.255.255.0 192.168.30.200

!

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 2 protocol ip permit

1727
Views
4
Helpful
5
Replies
CreatePlease to create content