Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DDR - Callback not working

Hi, I recently upgraded to IOS 12.3(20) a 28XX router used for RAS & Callback.

Before the upgrade the router was correcly doing the callback. After the upgrade (to deal with a issue of not recongnizing enough digits), the router no longer performs the callback.

This is the current (relevant part of the) configuration:

!

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

!

username xxxx callback-dialstring "" password <removed>

!

!

interface Serial2/0:15

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer-group 1

isdn switch-type primary-5ess

isdn incoming-voice modem

fair-queue

!

interface Group-Async1

ip unnumbered FastEthernet0/0

encapsulation ppp

autodetect encapsulation ppp

async mode interactive

peer default ip address pool XXXX

ppp callback accept

ppp authentication pap

group-range 33 62

hold-queue 10 in

!

!

line 33 62

exec-timeout 0 0

no flush-at-activation

script modem-off-hook offhook

script callback callback

modem InOut

transport preferred v120

transport input all

transport output none

autoselect ppp

!

The client connects succesfully, passes the Callback number, the router hangs up the call and remains idle aftewards.

I already tried with callback forced-wait 5, and no results.

The only strange thing is a line in the debug that reads:

*Mar 12 17:51:13.574: TTY39 callback unavailable on line for PPP Callback

In another similar debug, i got a line that reads:

Mar 12 18:46:59.429: TTY49 Callback process fail - modemcheck status=10081

I?ll attach a debug to this message

1 REPLY
New Member

Re: DDR - Callback not working

I solved the problem myself upgrading to the latest Cisco IOS version, 12.4(10). After the upgrade, the callback started working without any further configuration change.

154
Views
0
Helpful
1
Replies