Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dhcp excluded-address

Hi all,

i would ask you how can i modify my ip dhcp excluded-address .

My situation is like below:

 

ip dhcp excluded-address 10.22.93.1 10.22.93.20
ip dhcp excluded-address 10.22.93.199 10.22.93.254
!
 WIFI
   network 10.22.93.0 255.255.255.0
   default-router 10.22.93.1
   lease infinite

 

I would modify ip dhcp excluded-address 10.22.93.199 10.22.93.254 in ip dhcp excluded-address 10.22.93.230 10.22.93.254

it's enought do:

no ip dhcp excluded-address 10.22.93.199 10.22.93.254

ip dhcp excluded-address 10.22.93.230 10.22.93.254

 

Please answer me.

Regards

Paolo

 

 

4 REPLIES
New Member

clear ip dhcp bindings

clear ip dhcp bindings

New Member

So i need to do:conf tno ip

So i need to do:

conf t

no ip dhcp excluded-address 10.22.93.199 10.22.93.254

ip dhcp excluded-address 10.22.93.230 10.22.93.254

clear ip dhcp bindings

exit

wr mem

 

Right?

 

 

New Member

Please answer meRegardsPaolo

Please answer me

Regards

Paolo

New Member

UseThis command prevents IP

Use

This command prevents IP addresses from being assigned by the router's DHCP server. This is used to prevent IP conflicts with statically assigned servers and routers.

Syntax

Router(config)#ip dhcp excluded-address <low IP> <high IP>

Example

 


First we configure the DHCP server with ip dhcp pool and exclude the ip addresses.

R2(config)#ip dhcp pool R1_Pool
R2(dhcp-config)#network 10.22.93.0 /24
R2(dhcp-config)#dns-server 4.2.2.2
R2(dhcp-config)#default-router 10.22.93.1
R2(dhcp-config)#exit
R2(config)#ip dhcp excluded-address 10.22.93.230 10.22.93.254

Currently R1's Fa0/0 does not have an IP address
R1(config-if)#do show ip interface brief | ex unass

 

After we configure ip address dhcp on R1's Fa0/0, it receives an IP address of 10.22.93.1
R1(config)#int fa0/0
R1(config-if)#ip address dhcp
R1(config-if)#
*Mar 1 00:40:36.339: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.22.93.2 (FastEthernet0/0) is down: address changed

R1(config-if)#
*Mar 1 00:56:44.903: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 10.1.1.100, mask 255.255.255.0, hostname R1
R1(config-if)#
*Mar 1 00:41:21.567: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.22.93.2 (FastEthernet0/0) is up: new adjacency
R1(config-if)#

209
Views
0
Helpful
4
Replies