Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Dial-backup in 1841 and 2801

Please, does anyone know if 1841 and 2801 support dial-backup in AUX port using PPP ?

I am trying not use WIC-1AM.

Thanks,

Cleber

13 REPLIES

Re: Dial-backup in 1841 and 2801

Hi

Yes its possible.Pls refer to following link.

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080093d2b.shtml

Pls rate all helpful posts.

Regards

JD

Community Member

Re: Dial-backup in 1841 and 2801

Hi

i have a same problem.

i try to use async as a backup for serial.

when the s0 is down, i can see there is one action on async, but not up, it's down. i dont know why...

and when s0 go back to up, async go to standby.

could any tell me, why async cannot go up?

here is my config:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip cef

!

interface FastEthernet0/0

ip address 172.16.84.200 255.255.255.0 secondary

ip address 192.168.78.5 255.255.255.240

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

!

interface Serial0/0/0

bandwidth 64

backup delay 5 5

backup interface Async1

ip address 9.24.50.98 255.255.255.252

ip nat outside

ip virtual-reassembly

!

interface Async1

ip address 9.24.253.29 255.255.255.0

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer string 63295453

dialer-group 1

async mode dedicated

ppp authentication pap callin

ppp pap sent-username j password 0 jjj

routing dynamic

!

router eigrp 188

network 9.24.50.96 0.0.0.3

network 9.24.253.0 0.0.0.255

network 172.16.84.0 0.0.0.255

distribute-list 2 out Async1

distribute-list 2 out Serial0/0/0

no auto-summary

!

ip default-gateway 192.168.78.1

ip route 192.168.78.16 255.255.255.240 192.168.78.1

ip route 192.168.78.48 255.255.255.240 192.168.78.1

!

ip http server

no ip http secure-server

ip nat pool dynamic 172.16.84.1 172.16.84.200 netmask 255.255.255.0

ip nat inside source list 1 pool dynamic overload

ip nat inside source static 192.168.78.21 172.16.84.201

!

access-list 1 permit 192.168.78.0 0.0.0.255

access-list 2 permit 172.16.84.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

control-plane

!

line con 0

line aux 0

login local

modem InOut

modem autoconfigure discovery

flowcontrol hardware

line vty 0 4

!

scheduler allocate 20000 1000

!

end

Re: Dial-backup in 1841 and 2801

Hello,

I think you need a chat script to activate the line. Try and add the following to your config (additions are marked by -->):

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

--> chat-script async ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45

CONNECT \c

!

ip cef

!

interface FastEthernet0/0

ip address 172.16.84.200 255.255.255.0 secondary

ip address 192.168.78.5 255.255.255.240

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

!

interface Serial0/0/0

bandwidth 64

backup delay 5 5

backup interface Async1

ip address 9.24.x.x.255.255.252

ip nat outside

ip virtual-reassembly

!

interface Async1

ip address 9.24.x.x.255.255.0

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer string 63295453

dialer-group 1

async mode dedicated

ppp authentication pap callin

ppp pap sent-username j password 0 jjj

routing dynamic

!

router eigrp 188

network 9.x.x.96 0.0.0.3

network 9.x.x.0 0.0.0.255

network 172.16.84.0 0.0.0.255

distribute-list 2 out Async1

distribute-list 2 out Serial0/0/0

no auto-summary

!

ip default-gateway 192.168.78.1

ip route 192.168.78.16 255.255.255.240 192.168.78.1

ip route 192.168.78.48 255.255.255.240 192.168.78.1

!

ip http server

no ip http secure-server

ip nat pool dynamic 172.16.84.1 172.16.84.200 netmask 255.255.255.0

ip nat inside source list 1 pool dynamic overload

ip nat inside source static 192.168.78.21 172.16.84.201

!

access-list 1 permit 192.168.78.0 0.0.0.255

access-list 2 permit 172.16.84.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

control-plane

!

line con 0

line aux 0

--> script connection async

login local

modem InOut

modem autoconfigure discovery

flowcontrol hardware

line vty 0 4

!

scheduler allocate 20000 1000

!

end

Can you try this and check if it makes a difference ?

Regards,

GNT

Community Member

Re: Dial-backup in 1841 and 2801

Hi,

i tried this config on my router, i have to use

'script dialer async' to activate it. it will go on

using default script if 'script connection async'.

now seems the problem is on that script, here is my debug:

ug 3 04:02:17.795: CHAT1: Attempting async line dialer script

*Aug 3 04:02:17.795: CHAT1: Dialing using Modem script: async & System script:

none

*Aug 3 04:02:17.795: CHAT1: process started

*Aug 3 04:02:17.795: CHAT1: Asserting DTR

*Aug 3 04:02:17.795: CHAT1: Chat script async started

*Aug 3 04:02:17.795: CHAT1: Sending string: AT Z

*Aug 3 04:02:17.795: CHAT1: Expecting string: OK

*Aug 3 04:02:22.795: CHAT1: Timeout expecting: OK

*Aug 3 04:02:22.795: CHAT1: Chat script async finished, status = Connection tim

ed out; remote host not responding

I'm using one TPLink TM-EC5658V Modem.

thanx a lot!

Re: Dial-backup in 1841 and 2801

Hi

You need to configure that in bot of the routers.....

Regards

JD

Community Member

Re: Dial-backup in 1841 and 2801

sry, this is the debug with ur config:

*Aug 3 05:36:18.219: As1 DDR: place call

*Aug 3 05:36:18.219: As1 DDR: Dialing cause ip (s=9.24.253.29, d=224.0.0.10)

*Aug 3 05:36:18.219: As1 DDR: Attempting to dial 58845454

*Aug 3 05:36:18.219: CHAT1: Attempting async line dialer script

*Aug 3 05:36:18.219: CHAT1: Dialing using Modem script: async & System script:

none

*Aug 3 05:36:18.219: CHAT1: process started

*Aug 3 05:36:18.219: CHAT1: Asserting DTR

*Aug 3 05:36:18.219: CHAT1: Chat script async started

*Aug 3 05:36:18.219: CHAT1: Sending string: AT

*Aug 3 05:36:18.219: CHAT1: Expecting string: OK

*Aug 3 05:36:23.219: CHAT1: Timeout expecting: OK

*Aug 3 05:36:23.219: CHAT1: Chat script async finished, status = Connection tim

ed out; remote host not responding

*Aug 3 05:36:23.219: As1 DDR: disconnecting call

Re: Dial-backup in 1841 and 2801

HI

You need to configure the routers at both the sides.What is the response on other side?

Regards

JD

Community Member

Re: Dial-backup in 1841 and 2801

i only take responsible for one side,

and the other side is ok, i think, they already got connection with other dialers.

Re: Dial-backup in 1841 and 2801

Hi

In that case, we will require the config. of other side, b'coz we have to make sure that you are using their settings.The debug output seems to be OK with your side, there is some issue with the remote side.

Regards

JD

Community Member

Re: Dial-backup in 1841 and 2801

hi,

i got a news really really bad. maybe the problem is on my line, connecting modem and aux!

u know to connect modem i need a RS232-Rj45, and the RS232 head should be male.

there is one line shipped with router, RS232(female)-RJ45, so i bought one male-male commutator for it.

now i guess this commutator is the criminal.

i checked the AT commands by connect the modem to COM2 directly, and they can work.

and i noticed when the modem connect to computer, status light of 'TR' which means DTE ready is on.

but when i connect modem to router, TR is off!

what's very strange is, with this commutator, the router can find the async interface, after i config

aux.

how can i make sure the commutator is ok?

if not, how can i make one line, i mean how is the order of that line?

many thanx

Community Member

Re: Dial-backup in 1841 and 2801

sry, this is the debug with ur config:

*Aug 3 05:36:18.219: As1 DDR: place call

*Aug 3 05:36:18.219: As1 DDR: Dialing cause ip (s=9.24.253.29, d=224.0.0.10)

*Aug 3 05:36:18.219: As1 DDR: Attempting to dial 58845454

*Aug 3 05:36:18.219: CHAT1: Attempting async line dialer script

*Aug 3 05:36:18.219: CHAT1: Dialing using Modem script: async & System script:

none

*Aug 3 05:36:18.219: CHAT1: process started

*Aug 3 05:36:18.219: CHAT1: Asserting DTR

*Aug 3 05:36:18.219: CHAT1: Chat script async started

*Aug 3 05:36:18.219: CHAT1: Sending string: AT

*Aug 3 05:36:18.219: CHAT1: Expecting string: OK

*Aug 3 05:36:23.219: CHAT1: Timeout expecting: OK

*Aug 3 05:36:23.219: CHAT1: Chat script async finished, status = Connection tim

ed out; remote host not responding

*Aug 3 05:36:23.219: As1 DDR: disconnecting call

Re: Dial-backup in 1841 and 2801

Hi

Can you try following commands?Your config for serial is OK.

The chat script is there, I do not know what modem you have...I have used an Zyxel modem.

!

username cisco password 0 cisco

chat-script default ABORT ERROR ABORT BUSY ABORT "NO ANSWER" "" "ATDT\T" TIMEOUT 60 CONNECT \c

modemcap entry zyxel:FD=&F:AA=S0=1:CD=&C1:DTR=&D3:HFL=&H3:SPD=&B1:BER=&K4:NER=&K0:NEC=E0:NRS=Q1

!

interface Dialer 1

ip address 9.24.253.29 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer map snapshot 1 name broadcast

dialer map ip name modem-script default broadcast

dialer-group 1

pulse-time 3

ppp authentication chap

snapshot server 15 dialer

!

interface Async 1

no ip address

async mode dedicated

dialer rotary-group 1

dialer-list 1 protocol ip permit

line aux 0

autoselect ppp

modem InOut

modem autoconfigure discovery

transport input all

stopbits 1

speed 11500

flowcontrol hardware

Pls rate helpful posts.

Regards

JD

Community Member

Re: Dial-backup in 1841 and 2801

One related question: in 837 there is virtual AUX (whhere the CON can work as AUX), but is this case will I lost the console port to do management, for example ?

Thanks,

Cleber

251
Views
0
Helpful
13
Replies
CreatePlease to create content