Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dialer watch on DSL

Hi Guys..

I have a Cisco 2821 with a DSL WIC and normal fast ethernet connection.. im trying to backup the main interface by using dialer-watch on the ethernet.. backup interface isn't good enough cause I can't rely on line protocol..

If I configure dialer-watch on the dialer interface it doesn't kill the dialer, it has no effect whatsoever.. All I wanna know is, is this command supported on DSL at all? or is it only for old style ISDN stuff, i've seen some examples of it being used with DSL and Scott Morris's example on TCP mag,,, but I can't get it to work.. My config is pretty simple..

Interface dialer 1

ip addresses ect..

dialer watch-group 1

!

dialer watch-list 1 ip <tracked route>

Would be great if someone could let me know or offer any assistance.. I do have an alternative however if this works it would be great.... cheers

Tim

3 REPLIES

Re: Dialer watch on DSL

Hi Tim

You can look at going on for object tracking feature which can help you out to track you ethernet and trigger your dialer..

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fbeb.html

regds

New Member

Re: Dialer watch on DSL

Hi,

I've looked into this, I havn't found a way of triggering a dialer address with object tracking.. the DSL interface needs to be down when the normal interface is working, like it would be if the backup interface command was used, however I havn't figured out a way to do this with object tracking..

Cheers

Tim

New Member

Re: Dialer watch on DSL

Hello,

What you need to implement is Reliable Static Routing Backup Using Object Tracking:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hdia_c/part30/hdbackup.htm

Config Example:

conf t

rtr 1

type echo protocol ipIcmpEcho 172.16.35.1

exit

rtr schedule 1 life forever start-time now

track 123 rtr 1 reachability

exit

access-list 101 permit icmp any host 172.16.35.1 echo

access-list 102 deny icmp host 172.16.35.1 echo-reply any

access-list 102 permit ip any any

interface Serial1/0

ip access-group 102 in

interface Dialer0

ip access-group 102 in

exit

route-map LOCAL permit 10

match ip address 101

set ip next-hop 172.16.35.1

set interface Null0

exit

ip local policy route-map LOCAL

ip route 0.0.0.0 0.0.0.0 172.16.35.1 track 123

ip route 0.0.0.0 0.0.0.0 Serial1/0 254 10

PLS Rate if helpful.

273
Views
0
Helpful
3
Replies
CreatePlease login to create content