Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Dialer Watch

Hi All,

i 've configured ISDN on our remote router to be used as a bckup link in case the primary link goes down,

now for some strange reason if the primary link goes down the backup does not dial to the main site.

our primary link is a mpls connection meaning it's an ethernet connection connected to a ISP modem, in short its un-managed mpls.

any help would be great. thanks in advance

7 REPLIES

Re: Dialer Watch

Hi Zulqurnain

Since you are having your primary link connected on ethernet interface you need to have tracking feature configured on your router to track the primary link and fire the secondary connectivity.

do refer this link for more info..

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008042fbeb.html

regds

Re: Dialer Watch

Hello,

a couple of things in your configuration need to be changed. I have made some additions to your current config, one of them being the use of the physical BRI interface instead of the dialer. Also, the watched route needs to be referenced in a dialer map as well. And last but not least, deny EIGRP traffic to bring up the ISDN line.

Can you try this and see if it works better ?

isdn switch-type basic-net3

!

interface FastEthernet0/0

ip address 128.229.1.60 255.255.0.0

ip route-cache flow

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.13.38 255.255.255.252

duplex auto

speed auto

!

interface BRI0/0/0

description Back ISDN, Nr. 4697732

ip address 3.3.3.2 255.255.255.0

encapsulation ppp

no ip route-cache

no ip mroute-cache

load-interval 30

no keeplive

dialer map ip 3.3.3.1 name backupmain broadcast 4389000

dialer map ip 172.20.0.0 name backupmain broadcast 438900

dialer pool-member 1

dialer watch-list 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

!

router eigrp 10

passive-interface FastEthernet0/0

network 1.1.0.0 0.0.255.255

network 3.3.0.0 0.0.0.255

network 128.229.0.0

neighbor 1.1.0.1 Tunnel0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip http server

ip http secure-server

!

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer watch-list 1 ip 172.20.0.0 255.255.0.0

dialer-list 1 protocol ip list 101

Regards,

GNT

Bronze

Re: Dialer Watch

i tried your steps, but when i put the dialer map ip command i get message

remotebr(config-if)#dialer map ip 3.3.3.1 name backupmain broadcast 4389000

%Remove Dialer Profile Configuration first

remotebr(config-if)#dialer map ip 172.20.0.0 name backupmain broadcast 4389000

%Remove Dialer Profile Configuration first

Re: Dialer Watch

Hello,

remove:

dialer pool-member 1

from your BRI interface, and replace it with:

dialer-pool 1

that should get rid of the error message...

Regards,

GNT

Bronze

Re: Dialer Watch

hi

you mean dialer-group 1 right

because dialer pool 1 give the same message, also i tried with dialer-group 1 and same result below is my config

!

interface BRI0/0/0

description Back ISDN, Nr. 4697732

ip address 8.10.0.2 255.255.255.0

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

load-interval 30

dialer map ip 172.20.0.0 name backupmain broadcast 4389000

dialer map ip 8.10.0.1 name backupmain broadcast 4389000

dialer-group 1

isdn switch-type basic-net3

no keepalive

no cdp enable

ppp authentication chap

!

!

access-list 101 deny eigrp any any

dialer watch-list 1 ip 172.20.0.0 255.255.0.0

dialer-list 1 protocol ip list 101

Bronze

Re: Dialer Watch

hi all,

i am stuck in this problem, any one please help out, it just doesn't seems to work.

Re: Dialer Watch

You haven't enabled dialer watch on the BRI interface and ACL 101 needs another statement to permit all other IP traffic. Configure the following to your existing configuration.

int bri0/0

dialer watch-group 1

access-list 101 deny eigrp any any

access-list 101 permit ip any any

If you are still having problems, turn on debug dialer and make the watched route go away and post the output here.

HTH

Sundar

165
Views
0
Helpful
7
Replies
CreatePlease login to create content