Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DSL bridged: Lots of MAC addresses in ARP table

Hi all,

I am having a problem with my DSL line in bridged mode. It all works fine, but after a while my C837 dies on me.

When I checked the arp table, I discovered it's huge! It never stops growing and then the router hangs.

Is there something wrong with my config:

interface Ethernet0

description Internal LAN

ip address 192.168.32.1 255.255.255.0

no ip redirects

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/34

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

!

interface BVI1

description Tiscali Internet

mac-address 0025.6543.5268

ip address dhcp

ip access-group 110 in

no ip redirects

ip nat outside

ip inspect firewall out

no ip mroute-cache

arp timeout 20

!

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 1 address 0032.8660.b671 discard

My arp output:

router#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 71.111.92.116 0 000e.0000.0001 ARPA BVI1

Internet 86.72.93.67 0 000e.0000.0001 ARPA BVI1

Internet 82.174.151.107 0 000e.0000.0001 ARPA BVI1

Internet 83.78.126.99 0 000e.0000.0001 ARPA BVI1

Internet 24.11.189.174 0 000e.0000.0001 ARPA BVI1

Internet 82.152.59.241 0 000e.0000.0001 ARPA BVI1

Internet 219.237.138.189 0 000e.0000.0001 ARPA BVI1

Internet 68.54.19.96 0 000e.0000.0001 ARPA BVI1

Etc.

I put "arp timeout 20" in the BVI interface but this does not seem to help that much.

IOS level is: c837-k9o3y6-mz.123-2.XC2.bin

Any suggestions are welcome how I can prevent the huge number of MAC entries.

Thanks,

Rene

1 REPLY
Silver

Re: DSL bridged: Lots of MAC addresses in ARP table

Hi Rene ,

Try with the following command under interface BVI1.

no ip proxy-arp

Check the arp entries after configuring this command.

do you have any default route configured on the router.

Thanks,

satish

196
Views
0
Helpful
1
Replies
CreatePlease login to create content