cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
275
Views
0
Helpful
1
Replies

DSL w/831 router configuration questions

susan.brady
Level 1
Level 1

Hi all -

- DSL service with 1 static IP address

- DSL modem configured for "bridge mode"

- 831 router

There are some things I don't understand about all this.

#1: In order to make all this work, I need to have the PPPoE stuff configured on the router, yes?

#2: Do I need to have the "interface Dialer1" configured? And if not, can I put the DSL login info in the "interface Ethernet1" section?

#3: Do I need to explicitly set up NAT? I want my internal clients to get IPs on the 10.10.10.0 network and they need to have full Internet access.

#4: I think I don't understand how the routing should be set up.

#5: Any other helpful hints, I'll gladly take!!

Here's my config:

!This is the running config of the router: 10.10.10.1

!----------------------------------------------------------------------------

!version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging buffered 52000 debugging

enable secret xxxx

!

username user password xxxx

no aaa new-model

ip subnet-zero

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool CLIENT

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 205.152.xx.xx 205.152.xx.xx

lease 0 2

!

!

no ip domain lookup

ip audit notify log

ip audit po max-events 100

ip ssh break-string

no ftp-server write-enable

no scripting tcl init

no scripting tcl encdir

!

!

!

no crypto isakmp enable

!

!

!

!

interface Ethernet0

description Inside network$ETH-LAN$

ip address 10.10.10.1 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

!

interface Ethernet1

description Outside network, DSL connection

ip address 72.151.yy.yy 255.255.255.0

ip nat outside

duplex auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp pap sent-username username@isp.net password xxxx

!

ip nat inside source list 102 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet1 permanent

ip http server

no ip http secure-server

!

!

access-list 23 permit 10.10.10.0 0.0.0.255

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

!

control-plane

!

!

line con 0

exec-timeout 120 0

no modem enable

transport preferred all

transport output all

stopbits 1

line aux 0

transport preferred all

transport output all

line vty 0 4

access-class 23 in

exec-timeout 120 0

login local

length 0

transport preferred all

transport input all

transport output all

!

scheduler max-task-time 5000

!

end

1 Reply 1

MaseBarnes
Level 1
Level 1

I've mostly the same config, but eth1 with no ip address and modem NOT in bridge mode! Try this ...