Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dual ethernet fault tolerance and load balancing.

Here is the senario...Two ADSL services through two providers ADSL modems in bridge mode to two ethernet interfaces on say a Cisco 2800. How would the config look for this 2800 given 2 static ip services from thwe provider and NAT. This would be for simple internet access. Thanks, Shawn

4 REPLIES
Purple

Re: Dual ethernet fault tolerance and load balancing.

Hi Shawn,

You don't need to have 2 ethernet interfaces. If you want to bridge between your ADSL interfaces and these 2 ethernet interfaces, however, your router now becomes a bridge. I am assuming that that is not what you want and you simply want a way to terminate the bridged circuits. The config, then, is a slight variation on my response to your other post.

ip cef

!

interface atm1/0.32

ip address public IP from ISP1 255.255.255.252

ip nat outside

atm route-bridged ip

pvc 132

oam-pvc manage

!

interface atm2/0.32

ip address public IP from ISP2 255.255.255.252

ip nat outside

atm route-bridged ip

pvc 132

oam-pvc manage

!

interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.0

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 atm1/0.32

ip route 0.0.0.0 0.0.0.0 atm2/0.32

!

ip nat inside source route-map ISP1-map interface atm1/0.32

ip nat inside source route-map ISP2-map interface atm2/0.32

!

route-map ISP11-map permit 10

match interface atm1/0.32

!

route-map ISP12-map permit 10

match interface atm2/0.32

Explanation

- the use of two static routes will allow you to load-balance over the two links and provide redundancy at the same time

- the NAT config will dynamically choose the NAT'ed address depending on which interface CEF has chosen to send the packet out of...

Hope that helps - pls rate the post if it does.

Regards,

Paresh

New Member

Re: Dual ethernet fault tolerance and load balancing.

The hardware configuration would look somewhat like this. First there would be two static ADSL services from the provider. The services would be of the same rates. The provider would provide two ADSL modem/routers. These devices would be configured as simple transparent bridges. Each device has one ethernet jack. I would then take two cross-over cables to two interfaces on the Cisco 2800 and configure the static addresses on those interfaces. I'm looking for completely transparent load ballancing and fault tallerance for simple internet access with this configuration. I dought the customer will want to bone up for the addition of two WIC-1ADSL cards. This customer is the king of doing more with less. How would a simple config look for this? Thanks so much in advance, Shawn

Purple

Re: Dual ethernet fault tolerance and load balancing.

Try this:

ip cef

!

interface eth0/1

description To ISP1

ip address 255.255.255.252

ip nat outside

!

interface eth0/2

description To ISP2

ip address 255.255.255.252

ip nat outside

!

interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.0

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 eth0/1

ip route 0.0.0.0 0.0.0.0 eth0/2

!

ip nat inside source route-map ISP1-map interface eth0/1

ip nat inside source route-map ISP2-map interface eth0/2

!

route-map ISP11-map permit 10

match interface eth0/1

!

route-map ISP12-map permit 10

match interface eth0/2

Explanation:

- the use of two static routes will allow you to load-balance over the two links and provide redundancy at the same time

- the NAT config will dynamically choose the NAT'ed address depending on which interface CEF has chosen to send the packet out of...

- this will give you completely transparent load balancing and fault tolerance

Hope that helps - pls rate the post if it does.

Regards,

Paresh

New Member

Re: Dual ethernet fault tolerance and load balancing.

So did this work? I was looking to do the same on 2811 - with one HWIC-1ADSL and one HWIC-CABLE-D-2.

190
Views
0
Helpful
4
Replies
CreatePlease login to create content