Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

E1 Controller configuration

Hello,

i have Cisco RAS5300, and i never have worked on controller E1 befor,

i will connect the E1 ports to a PSTN so that people can dialin and connect to the RAS.

what do i need to configure? and what is the use of the seial interfaces and if i will need them?

below is my sh run:

Current configuration : 1874 bytes

!

version 12.3

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MANS-AS5300

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

spe 1/0 2/9

firmware location system:/ucode/mica_port_firmware

!

!

resource-pool disable

!

aaa new-model

!

!

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

!

!

username xxxx password 0 xxxx

!

!

controller E1 0

clock source line primary

!

controller E1 1

clock source line secondary 1

!

controller E1 2

clock source line secondary 2

!

controller E1 3

clock source line secondary 3

!

controller E1 4

clock source line secondary 4

!

controller E1 5

clock source line secondary 5

!

controller E1 6

clock source line secondary 6

!

controller E1 7

clock source line secondary 7

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

shutdown

clock rate 2015232

no fair-queue

!

interface Serial1

no ip address

shutdown

clock rate 2015232

no fair-queue

!

interface Serial2

no ip address

shutdown

clock rate 2015232

no fair-queue

!

interface Serial3

no ip address

shutdown

clock rate 2015232

no fair-queue

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.254

no ip http server

!

!

!

!

!

!

line con 0

line 1 240

line aux 0

line vty 0 4

!

end

thanks for any help.

5 REPLIES
Blue

Re: E1 Controller configuration

when you configure a 'controller' properly for use, it will create serial interface(s) on the router that you will then need to configure to complete the connectivity via E1.

(it's actually easier than it sounds)

the E1 can be configured for common channel signaling (CCS) or channel associated signaling (CAS).

please see the following links for info on configuring an E1 controller:

PRI E1 (CCS):

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configuration_guide_chapter09186a00800d9842.html#wp1000872

channelized E1 (CAS):

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/as5800/58sw_icg/swconfig.htm#xtocid445814

New Member

Re: E1 Controller configuration

Hello & thanks for your reply,

i looked at the documet which was very helpfull, the channalized one.

i would like to ask:

which type of E1 do i need? PRI or channalized?

my typical use is to connect the RAS to our PSTN, and people can dial in , we will have 8x30 dialin ports (240).

also, i can configure the E1 as the documents provided information, but what about Serail interface? why do i have to configure it? and do i have to connect the physical serial interface somewhere? i have 4 serials in my RAS.

Thanks for any info,

Re: E1 Controller configuration

May be you are getting confused betwween controller and serial interfaces :

1st case:If configured as a unframed serail interface numbering is same as for controller only need to add group number.

controller E1 3/0

channel-group 0 unframed

!

interface Serial3/0:0

description ** UNUSED **

no ip address

ip load-sharing per-packet

shutdown

no cdp enable

2nd case:here you can alocate bandwidth for channels.serial port numbing is same as for controller add corresponding channel group.

controller E1 5/0

channel-group 0 timeslots 1-4

channel-group 1 timeslots 5-6

channel-group 2 timeslots 7-8

channel-group 4 timeslots 11-12

channel-group 5 timeslots 13

channel-group 6 timeslots 14-15

channel-group 7 timeslots 16-17

channel-group 8 timeslots 18-19

channel-group 9 timeslots 20-21

!

interface Serial5/0:0

description ***** UNUSED******

ip address 203.195.147.254 255.255.255.252

encapsulation ppp

no cdp enable

3rd case:IF configuring PRI

controller E1 4/0

pri-group timeslots 1-31

description <>

chennel 15 is being used for singalling .

interface Serial4/0:15

description ### PRI Number###

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

dialer pool-member 3

now create a dialer with ip config.

interface Dialer1

description "UNSED"

bandwidth 64

ip address 172.19.112.26 255.255.255.252

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer idle-timeout 300

dialer-group 1

autodetect encapsulation ppp

ppp authentication chap callin

New Member

Re: E1 Controller configuration

Hello sir,

thanks for the configuration.

after i do:

controller E1 0

channel-group 0 timeslots 1-30

!

interface Serial0.15

..

..

..

!

my RAS is connected to the internet through FastEthernet0.

but i still dont know why do i have to configure a logical serial interface and a Dialer?

cant i configure the channalized E1 lines 1-240 for ppp , modem inout , etc.. ?

thanks

Re: E1 Controller configuration

see whatever you are configuring PRI/channelized E1 30 channels are there incase suppose u have 30 Links of 64 Kbps you have to configure 30 serial links like s1/0:0----s1/0:30 or may be dialer1-255 but at a time 30 in/out call will be in use.Chjennalized e1 we use for Lease Line and PRI for dial-up Hope you got the answer for your question.

1778
Views
0
Helpful
5
Replies
CreatePlease login to create content