Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Getting very slow DSL speed on my 1721 router

I have a 1721 with an ethernet WIC cloned to a dialer interface. The WIC goes out to a DSL modem. My issue is that ever since I deployed this router, the speed has been diminished enough to make people complain. Its a 3mb circuit, but this is what I show when I pull up the dialer interface:

Dialer0 is up, line protocol is up (spoofing)

Hardware is Unknown

Internet address is <MASKED>

MTU 1500 bytes, BW 3000 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 11/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Interface is bound to Vi1

Last input never, output never, output hang never

Last clearing of "show interface" counters 1d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 2250 kilobits/sec

5 minute input rate 133000 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

603534 packets input, 698765983 bytes

394642 packets output, 47367523 bytes

Bound to:

Virtual-Access1 is up, line protocol is up

Hardware is Virtual Access interface

MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 22/255, rxload 51/255

Encapsulation PPP, LCP Open

Open: IPCP

PPPoE vaccess, cloned from Dialer0

Vaccess status 0x44, loopback not set

Keepalive set (10 sec)

Interface is bound to Di0 (Encapsulation PPP)

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters 20:11:48

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 174000 bits/sec, 7 packets/sec

5 minute output rate 5000 bits/sec, 5 packets/sec

427406 packets input, 470254490 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

295171 packets output, 36634198 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

As you can see, the virtual-Access1 interface is showing bandwidth of 56Kbit, whisch looks like ths slowness issue. What do I need to change on my config to get this speed to where it is supposed to be? Here is my currect interfaces config:

interface Loopback0

no ip address

shutdown

!

interface Ethernet0

no ip address

ip virtual-reassembly

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Ethernet0.1

shutdown

no cdp enable

!

interface FastEthernet0

description local LAN

ip address <MASKED>

ip nbar protocol-discovery

ip nat inside

ip virtual-reassembly

speed 100

full-duplex

no cdp enable

!

interface Virtual-Template1

no ip address

!

interface Dialer0

bandwidth 3000

bandwidth inherit 3000

ip address <MASKED>

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname <MASKED>t

ppp chap password 7 <MASKED>

ppp pap sent-username <MASKED> password 7 <MASKED>

crypto map *********

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

Thanks for any help!

  • Remote Access
4 REPLIES

Re: Getting very slow DSL speed on my 1721 router

Your config looks fairly OK to me. The bandwidth setting on the virtual interface is merely administrative and I do not think it affects the performance in any way.

I think it can be changed by modifying the bandwidth setting on interface Virtual-Template1.

For the poor performance, I think you should rather check the overbooking rate on the link and/or contact your provider.

regards,

Leo

New Member

Re: Getting very slow DSL speed on my 1721 router

Is there any chance the IOS type could be doing this? I am currently using c1700-advsecurityk9-mz.124-1c.bin

Re: Getting very slow DSL speed on my 1721 router

With such a low release number, there is always a chance for that. However, with an old platform like the 1700, I would not try an upgrade. Reason for this: newer releases also draw heavier on the system resources.

Try downgrading to a stable image in the 12.3 train instead.

regards,

Leo

New Member

Re: Getting very slow DSL speed on my 1721 router

I sent them a 1700 with a DSL WIC to see if that helps. It has a 12.4 release, but I can always downgrade it remotely if need be. I do NOT like up/downgrading IOS images remotely because of the problems that may arise, but it is what it is.

Can someone have a look at this config to see if it looks ok? Thanks!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

description local LAN

ip address *.*.*.* 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

no cdp enable

!

interface Dialer0

ip address *.*.*.* 255.255.255.248

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname ****@pacbell.net

ppp chap password 7 ***********

ppp pap sent-username ****@pacbell.net password 7 *********

crypto map ****_map

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

355
Views
0
Helpful
4
Replies
This widget could not be displayed.