Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ian
New Member

How do I set a 804 ISDN router to connect on startup?

I am using a Cisco 804 ISDN router. Unfortunately due to area constraints this is what we have to use. I need this to dial out at router startup. I have dug through config option, this forum, and over Internet and can't find a solution anywhere. I have it set for no idle timeout and have tried multiple threshold settings to try to get this to work.

4 REPLIES

Re: How do I set a 804 ISDN router to connect on startup?

Hi

can you post your config here and also the exact requirement you have in place out there ?

regds

ian
New Member

Re: How do I set a 804 ISDN router to connect on startup?

This is a Cisco 804 ISDN router being used for a internet and remote access for the customer. It needs to be able to be up 24/7. As such it needs to automatically connect and if possible reconnect if the connection is dropped. I have searched everywhere on this and can't seem to find what I am looking for.

===========Current Config==============

no service udp-small-servers

no service tcp-small-servers

service password-encryption

hostname

username password

enable secret

no ip source-route

isdn switch-type basic-ni

ip routing

ip classless

ip subnet-zero

pots country US

dial-peer voice 1 pots

destination-pattern 3430315

port 1

dial-peer voice 2 pots

destination-pattern 3431591

port 2

interface ethernet 0

keepalive

no shutdown

ip address 66.x.x.x.255.255.252

ip route-cache

no ip proxy-arp

no ip directed-broadcast

ip access-group 121 in

interface bri 0

encapsulation ppp

ppp authentication chap pap callin

ppp multilink

isdn switch-type basic-ni

isdn spid1 54134303151111 3430315

isdn spid2 54134315911111 3431591

dialer pool-member 1

isdn incoming-voice modem

no shutdown

interface dialer 1

dialer remote-name Cisco1

dialer pool 1

no ip split-horizon

description ISP

encapsulation ppp

dialer idle-timeout 300

dialer hold-queue 10

dialer-group 1

dialer string 7621234 class DialClass

ppp authentication pap callin

ppp pap sent-username xxx password xxx

ppp multilink

ip address negotiated

ip route-cache

no ip proxy-arp

no ip directed-broadcast

ip access-group 121 in

map-class dialer DialClass

dialer isdn speed 56

dialer-list 1 protocol ip permit

no router rip

ip route 0.0.0.0 0.0.0.0 dialer 1

access-list 18 permit 66.178.130.44 0.0.0.3

access-list 121 deny udp any eq 138 any

access-list 121 deny udp any eq 137 any

access-list 121 deny udp any eq 139 any

access-list 121 deny tcp any eq 137 any

access-list 121 deny tcp any eq 138 any

access-list 121 deny tcp any eq 139 any

access-list 121 permit ip any any time-range TIME

time-range TIME

periodic daily 00:00 to 23:59

line console 0

exec-timeout 120

line vty 0 4

exec-timeout 0

login local

end

=============================

New Member

Re: How do I set a 804 ISDN router to connect on startup?

To bring up & nail up the isdn connection use any of the below options

1) Use Dialer persistent as explained by the below link

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080454ff8.html

Note this nails the conection up even with no traffic

2) Configure NTP or a routing protocol to generate interesting traffic

PS.

- You currently have an idle-timeout of 300sec use the max value or 0 to nail it up

- threshold settings is used to bring up an additional B channel

ian
New Member

Re: How do I set a 804 ISDN router to connect on startup?

Thanks for the response. dialer persistant didn't work because I was only using IOS 12.1. I was however able to get SNTP to set traffic out to bring up the connection. Thank you for the assistance.

141
Views
7
Helpful
4
Replies
CreatePlease to create content