Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

IP Cef with nat in pppoe conf

I have a question:

When i disable ip cef the pppoe client session work ok and when I enable ip cef have not connection .Where is the problem.

this is the configuration:

aaa authentication login default local

aaa authentication ppp default local group radius

aaa authorization network default if-authenticated

aaa accounting network default start-stop group radius

ip cef

username xxx password xxx

!

bba-group pppoe pppoevlan1

virtual-template 140

sessions per-vc limit 500

!

interface GigabitEthernet0/1

ip address x.x.x.246 255.255.255.240

ip nat outside

interface GigabitEthernet0/2

no ip address

interface GigabitEthernet0/2.1

description PPPOE VLAN 1

encapsulation dot1Q 1 native

ip address 192.168.140.1 255.255.255.0

ip virtual-reassembly

no snmp trap link-status

pppoe enable group pppoevlan1

!

interface Virtual-Template140

ip unnumbered GigabitEthernet0/2.1

ip nat inside

ip virtual-reassembly

peer default ip address pool pppoevlan1

ppp authentication chap

ppp multilink

!

ip local pool pppoevlan1 192.168.140.2 192.168.140.253

ip nat inside source list 40 pool pppoenat overload

access-list 40 permit 192.168.140.0 0.0.0.255

1 REPLY
Silver

Re: IP Cef with nat in pppoe conf

TCP traffic may get dropped if Cisco Express Forwarding (CEF) and Network Address Translation (NAT) are both enabled.

Make sure you are using the version 12.2.8T.

438
Views
0
Helpful
1
Replies