Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN Call firing issue.

Dear Friends ,

I am facing a peculiar issue with ISDN .

For a particular customer , in a 3 tier architecture ,we use 2 backups .

backup 1 , if the leased line fails , the access router fires the isdn ,connecting it to the distribution layer .

If backup 1 fails , we manually fire isdn form the core router to the access site .

Now the issue is , I am not able to call my access site from the core . But strange enough , I am able to fire a test call to the core from the same access router.

I have racked my brain on this .

Need your help to arrive towards a solution.

Thanks

Warm Regards

Glenn.

6 REPLIES

Re: ISDN Call firing issue.

Hi Glenn

do post out a N/W diagram along with the relevant config of the routers.

regds

Hall of Fame Super Gold

Re: ISDN Call firing issue.

Glenn

I have seen a scenario that produces results very much like the issue that you describe. The scenario involves configuring a router with dial where dialer profiles are configured. In the configuration there is authentication configured in the dialer profile but not configured on the physical interface (BRI or whatever). Since outgoing calls use the dialer profile where authentication is configured the call can authenticate and the call is successful. But an incoming call rings the physical interface, but since it does not have authentication configured it can not authenticate and the incoming call fails.

So is it possible that the remote access router is configured with dialer profiles, and that the dialer profile has authentication but the physical interface does not have authentication configured?

HTH

Rick

New Member

Re: ISDN Call firing issue.

hey Rick ,

The configuration for the Remote BRI is

interface BRI0/0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

ppp authentication chap

ppp multilink

The authentication is configured on the physical interface.

But i feel some how , the call is not even landing on the remote end!

New Member

Re: ISDN Call firing issue.

for the core

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

pri-group timeslots 1-31

track timer interface 5

!

track 123 rtr 1 reachability

delay down 5 up 5

!

!

!

!

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

ppp authentication chap

ppp multilink

!

interface Serial1/1:15

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-net5

ppp authentication chap

ppp multilink

!

interface Dialer1

bandwidth 2048

ip address 172.17.0.1 255.255.128.0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 300000

dialer load-threshold 1 either

dialer-group 1

ppp authentication chap

ppp multilink

!

interface Dialer2

ip address 172.29.1.2 255.255.255.0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 300000

dialer load-threshold 1 either

dialer-group 1

ppp authentication chap

ppp multilink

!

interface Dialer10

no ip address

!

interface Dialer12

no ip address

!

interface Dialer21

no ip address

!

access-list 101 permit ip any any

access-list 161 deny ip any host 172.25.4.53

dialer-list 1 protocol ip permit

!

end

------------------------

At the access.

!

interface BRI0/0/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

ppp authentication chap

ppp multilink

!

!

!

interface Dialer1

description ### ISDN VADODRA NAP ###

bandwidth 64

ip address 172.23.125.244 255.255.255.128

encapsulation ppp

dialer pool 1

dialer remote-name VAD-RTR-02

dialer idle-timeout 300

dialer string

dialer load-threshold 125 either

dialer-group 1

ppp authentication chap

ppp multilink

!

interface Dialer2

description ### ISDN , DC ###

bandwidth 64

ip address 172.17.3.238 255.255.128.0

encapsulation ppp

dialer pool 1

dialer remote-name DC-ISDN-RTR-01

dialer idle-timeout 300

dialer load-threshold 125 either

dialer-group 1

ppp authentication chap

ppp multilink

!

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 172.23.125.129 100 track 1

ip route 0.0.0.0 0.0.0.0 Dialer2 172.17.0.1 200 track 2

ip route 0.0.0.0 0.0.0.0 Serial0/1/0

ip route 0.0.0.0 0.0.0.0 Dialer3 172.17.128.1 250

!

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

Some part of the configuration are clipped for obvious reasons!

Hall of Fame Super Gold

Re: ISDN Call firing issue.

Glenn

I am not sure why the remote includes isdn point-to-point-setup in the configuration of the BRI. I have seen some situations where having that in the config did create some problems. I suggest that you remove it and see if the behavior changes.

If the problem still is going on then I would suggest that it might be helpful to do some more testing, trying to make a call from the core while running debug isdn q931 and perhaps debug ppp authentication.

HTH

Rick

Re: ISDN Call firing issue.

Hi,

Please check with the isp if you have the PRI lines for both usage.

Incomming as well as outgoing. This may be the problme with the ISP.

What Rburts said before about incomming call makes sence since you configuration also is right it does not seems to be problem.

I also see SLA Configuration do u know what you are tracking ?

Hope this helps.

513
Views
0
Helpful
6
Replies
CreatePlease to create content