Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ISDN Config Problem on 1601R

Hi all,

I need an expert advice to solve a problem with a dial-up access configuration .

I tried different configurations but the communication doesn't last more than 30 seconds .

I also issued some debug commands like :

debug ppp dialer events

debug ppp negotiation

debug ppp autentication

and so on .

In the attached file you'll find some configurations I tried and and image regarding the "show isdn status" command.

Thanks in advance

2 REPLIES

Re: ISDN Config Problem on 1601R

Your config looks fairly ok on first sight. However, you are missing an ip nat outside on config nr 3. The fact that calls are disconnected within 30s may likely be due to a ppp negotiation problem.

Could you please post the output for: deb ppp neg?

Regards,

Leo

Bronze

Re: ISDN Config Problem on 1601R

Hello,

looking at the three different configurations, a couple of questions: what are you connecting to ? The remote name is ´ciscov´, and since you have configured ´ip address negotiated´, that remote router has to give out the IP address. Is ´ciscov´ configured for that ? If so, does ´ciscov´ have the PAP or CHAP name of your local router in its database ?

You could try and use fixed IP addresses on both sides, configure each other´s username in the local database, and also configure ´ppp authentication chap pap´, that is, without the ´callin´ option.

Anyway, without knowing the exact details of your network, I have tried and merged a few things together from the three configs you posted:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

interface FastEthernet0/0

ip address 192.168.0.254 255.255.255.0

no ip directed-broadcast

ip nat inside

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

!

interface BRI1/0

no ip address

no ip directed-broadcast

encapsulation ppp

ppp multilink

dialer pool-member 1

ppp autentication pap chap callin

isdn switch-type basic-net3

!

interface BRI1/1

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/2

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface BRI1/3

no ip address

no ip directed-broadcast

shutdown

isdn switch-type basic-net3

!

interface Dialer0

ip address negotiated

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer string 7027020000

dialer remote-name ciscov

dialer-group 1

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname xxxxx

ppp chap password xxxxx

ppp pap sent-username xxxxxxxxxxxxxx password xxxx

ppp multilink

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

access-list 1 permit 192.168.0.0 0.0.0.255

dialer-list 1 protocol ip permit

!

line con 0

logging synchronous

transport input none

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

Regards,

Nethelper

107
Views
0
Helpful
2
Replies