Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

ISDN dialin BRI interface

Hi

I would like to configure the 1812 BRI interface to accept ISDN dialin for the maintenance work.

if you could show the sample configuration, I will be grateful.

regards

2 REPLIES
Silver

Re: ISDN dialin BRI interface

Hi ,

Can you give a brief description of your current setup means which router is connected to 1812 for isdn connectivity.

example:

1812 --------- 3640

The following is the config for dialin for 1812.

1812:

usrname XXXXX password XXXX

int bri X

ip address XXXX XXXX

encapsulation ppp

isdn-switch type XXXX

isdn caller XXXX

ppp authentication chap

PPP chap password XXXX

ppp chap hostname XXXX

dialer-group 1

config)# dialer-list 1 protocol ip permit

3640 router:

username XXXX password XXXX

int bri X

ip address XXXX XXXX

encapsulation ppp

isdn switch-type XXXX

dialer string XXXX

ppp chap hostname XXXX

ppp authentication chap

ppp chap password

dialer-group 1

config)# dialer-list 1 protocol ip permit

3640 dials 1812 router.

hope this helps....plz rate it..

Thanks

satish

New Member

Re: ISDN dialin BRI interface

Thanks for you reply

Well, I would like to have dialin config for the ISDN dialup (connection modem to BRI interface)

1, login to router by telnet

2, login to the network

Could you check the config & debug ?

config;

aaa new-model

aaa authentication login default local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin local

aaa authorization network default local

username cisco privilege 15 secret 5 $1$5B3f$5v2STaD3vTaHcdC/BCHWs1

username pppuser password 0 pppuser

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

ip unnumbered FastEthernet0

encapsulation ppp

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

peer default ip address pool POOL

no cdp enable

ppp authentication chap pap

!

ip local pool POOL 192.168.1.2

debug;

PPP / ISDN

*Jan 23 14:06:43.347: ISDN BR0 Q921: User RX <- UI sapi=0 tei=127

*Jan 23 14:06:43.347: ISDN BR0 Q931: SETUP pd = 8 callref = 0x01

Sending Complete

Bearer Capability i = 0x8890

Standard = CCITT

Transfer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Exclusive, B1

Called Party Number i = 0xA1, '21'

Plan:ISDN, Type:National

*Jan 23 14:06:43.351: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x3E calltype 1 HOST_INCOMING_CALL

*Jan 23 14:06:43.351: ISDN BR0 EVENT: host_incoming_call: call_id 0x003E, Guid = C9C7C6DA8034 bchan 0

*Jan 23 14:06:43.351: ISDN BR0 EVENT: UserIdle: callid 0x3E received ACCEPT_CALL (0x13)

*Jan 23 14:06:43.351: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

*Jan 23 14:06:43.351: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to N/A N/A

*Jan 23 14:06:43.351: BR0:1 PPP: Using dialer call direction

*Jan 23 14:06:43.351: BR0:1 PPP: Treating connection as a callin

*Jan 23 14:06:43.351: BR0:1 PPP: Session handle[CC000030] Session id[44]

*Jan 23 14:06:45.347: BR0:1 LCP: Timeout: State Listen

*Jan 23 14:06:45.347: BR0:1 PPP: Authorization required

*Jan 23 14:06:45.347: BR0:1 LCP: O CONFREQ [Listen] id 86 len 15

*Jan 23 14:06:45.347: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

*Jan 23 14:06:45.347: BR0:1 LCP: MagicNumber 0x1C669BCD (0x05061C669BCD)

*Jan 23 14:06:47.335: ISDN BR0 Q921: User RX <- UI sapi=0 tei=127

*Jan 23 14:06:47.335: ISDN BR0 Q931: SETUP pd = 8 callref = 0x01

Sending Complete

Bearer Capability i = 0x8890

Standard = CCITT

Transfer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x89

Exclusive, B1

Called Party Number i = 0xA1, '21'

Plan:ISDN, Type:National

*Jan 23 14:06:47.363: BR0:1 LCP: Timeout: State REQsent

*Jan 23 14:06:47.363: BR0:1 LCP: O CONFREQ [REQsent] id 87 len 15

*Jan 23 14:06:47.363: BR0:1 LCP: AuthProto CHAP (0x0305C22305)

*Jan 23 14:06:47.363: BR0:1 LCP: MagicNumber 0x1C669BCD (0x05061C669BCD)

*Jan 23 14:06:49.351: ISDN BR0 Q931: Ux_DLRelInd: DL_REL_IND received from L2

*Jan 23 14:06:49.351: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x3E calltype 1 HOST_DISCONNECT_ACK

*Jan 23 14:06:49.351: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from unknown , call lasted 6 seconds

*Jan 23 14:06:49.351: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down

regards

224
Views
0
Helpful
2
Replies
CreatePlease to create content