Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

L2TP VPDN with Radius

Hi Everyone,

I've Configured L2TP server with Radius Authentication, client is client initiated L2TP , config in the attachment, authentication with radius okay but the router won't pass the attribute especially the ip address (when the router in debug mode it receive the attribute from radius, so i'm very sure the radius is working ) . I've several remote access connection, so the aaa is not using default instead I define per "WORD" that's telco.

here is the configuration

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa authentication ppp telco group radius

aaa authorization exec telco group radius

aaa authorization network telco group radius

aaa authorization configuration telco group radius

aaa accounting network telco start-stop group radius

vpdn-group 1

! Default L2TP VPDN group

accept-dialin

protocol l2tp

virtual-template 1

no l2tp tunnel authentication

interface Loopback0

ip address 1.1.1.x.x.255.255

interface Tunnel0

ip unnumbered Serial1/0.86

tunnel source 192.168.12.90

tunnel destination 202.x.x.1

interface Serial1/0.86 point-to-point

description none

bandwidth 56

ip address 192.168.12.90 255.255.255.252

no cdp enable

frame-relay interface-dlci 86

interface Virtual-Template1

ip unnumbered Loopback0

no peer default ip address

vpdn authorization telco

ppp authentication chap telco

ip route 10.225.1.0 255.255.255.252 10.225.0.5

ip route 10.128.25.0 255.255.255.0 Tunnel0

radius-server attribute 8 include-in-access-req

radius-server host 10.224.1.32 auth-port 1812 acct-port 1813 key xxx

2 REPLIES
New Member

Re: L2TP VPDN with Radius

I think you should take a look at "radius-server configure-nas" and http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/secur_c/scprt2/scrad.htm

1007
Views
3
Helpful
2
Replies
CreatePlease to create content