Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Load Balancing on DSL link

Dear All,

We are having 2 internet link from 2 separate ISP.

Please help me in doing load balancing on this 2 ADSL LINK.

Thanks/Regards

Atul

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Load Balancing on DSL link

Hello,

here is a sample configuration for load balancing with 2 links:

ip cef

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer1

description ISP1_Connection_1

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description ISP1_Connection_2

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

!

access-list 1 permit 192.168.1.0

!

route-map ISP1_Connection_1 permit 10

match ip address 1

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match ip address 1

match interface Dialer2

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

dialer-list 1 protocol ip permit

Regards,

GP

2 REPLIES
New Member

Re: Load Balancing on DSL link

Configure CEF on the router and then you can load balance per destination or per packet.

VIP Purple

Re: Load Balancing on DSL link

Hello,

here is a sample configuration for load balancing with 2 links:

ip cef

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer1

description ISP1_Connection_1

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description ISP1_Connection_2

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

!

access-list 1 permit 192.168.1.0

!

route-map ISP1_Connection_1 permit 10

match ip address 1

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match ip address 1

match interface Dialer2

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

!

dialer-list 1 protocol ip permit

Regards,

GP

150
Views
5
Helpful
2
Replies
CreatePlease login to create content