Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Modem for maintenance use (I'm down)

Hello all!

There are many sample configs on Cisco web site. So I follow after it, imitate it.

I set up an OMRON modem with a EIA/TIA-232-c interface. It connects with Cisco 2500's Serial 0. But I don't know whether it works or not. (´・ω・`) What must I do next phase?

R-22#sh run

Building configuration...

Current configuration : 1243 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R-22

!

enable secret xxxx

enable password xxx

!

username xxx password xxx

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface Ethernet0

ip address 192.168.29.1 255.255.255.0

!

interface Ethernet1

no ip address

shutdown

!

interface Serial0

no ip address

no fair-queue

!

interface Serial1

no ip address

shutdown

!

interface Group-Async1

physical-layer async

ip unnumbered Ethernet0

encapsulation ppp

async mode interactive

peer default ip address pool dialup

no cdp enable

ppp authentication chap

!

ip local pool dialup 192.168.39.239 192.168.39.254

ip classless

ip http server

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

exec-timeout 20 0

password xxx

login

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

flowcontrol software

line vty 0 4

exec-timeout 20 0

password xxxx

login

modem autoconfigure discovery

transport input pad v120 telnet rlogin udptn

autoselect during-login

autoselect ppp

stopbits 1

flowcontrol software

!

end

Thanks.

9 REPLIES
New Member

Re: Modem for maintenance use (I'm down)

Hiya!

There are some other outputs below.

R-22#sh int s0

Serial0 is down, line protocol is down

Hardware is HD64570

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=up DTR=up RTS=up CTS=up

R-22#sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 0 CTY - - - - - 0 0 0/0 -

1 AUX 9600/9600 - - - - - 0 0 0/0 -

2 VTY - - - - - 0 0 0/0 -

3 VTY - - - - - 0 0 0/0 -

4 VTY - - - - - 0 0 0/0 -

5 VTY - - - - - 0 0 0/0 -

6 VTY - - - - - 0 0 0/0 -

R-22#

R-22#sh controllers s 0

HD unit 0, idb = 0x141B18, driver structure at 0x147EA0

buffer size 1524 HD unit 0, RS-232 DTE cable

cpb = 0x2, eda = 0x2940, cda = 0x2800

RX ring with 16 entries at 0x4022800

00 bd_ptr=0x2800 pak=0x149394 ds=0x4026108 status=80 pak_size=0

01 bd_ptr=0x2814 pak=0x1495E8 ds=0x40267C4 status=80 pak_size=0

02 bd_ptr=0x2828 pak=0x14983C ds=0x4026E80 status=80 pak_size=0

03 bd_ptr=0x283C pak=0x149A90 ds=0x402753C status=80 pak_size=0

04 bd_ptr=0x2850 pak=0x149CE4 ds=0x4027BF8 status=80 pak_size=0

05 bd_ptr=0x2864 pak=0x149F38 ds=0x40282B4 status=80 pak_size=0

06 bd_ptr=0x2878 pak=0x14A18C ds=0x4028970 status=80 pak_size=0

07 bd_ptr=0x288C pak=0x14A3E0 ds=0x402902C status=80 pak_size=0

08 bd_ptr=0x28A0 pak=0x14A634 ds=0x40296E8 status=80 pak_size=0

09 bd_ptr=0x28B4 pak=0x14A888 ds=0x4029DA4 status=80 pak_size=0

10 bd_ptr=0x28C8 pak=0x14AADC ds=0x402A460 status=80 pak_size=0

11 bd_ptr=0x28DC pak=0x14AD30 ds=0x402AB1C status=80 pak_size=0

12 bd_ptr=0x28F0 pak=0x14AF84 ds=0x402B1D8 status=80 pak_size=0

13 bd_ptr=0x2904 pak=0x14B1D8 ds=0x402B894 status=80 pak_size=0

14 bd_ptr=0x2918 pak=0x14B42C ds=0x402BF50 status=80 pak_size=0

15 bd_ptr=0x292C pak=0x14B680 ds=0x402C60C status=80 pak_size=0

16 bd_ptr=0x2940 pak=0x14B8D4 ds=0x402CCC8 status=80 pak_size=0

cpb = 0x2, eda = 0x3000, cda = 0x3000

TX ring with 4 entries at 0x4023000

00 bd_ptr=0x3000 pak=0x000000 ds=0x000000 status=80 pak_size=0

01 bd_ptr=0x3014 pak=0x000000 ds=0x000000 status=80 pak_size=0

02 bd_ptr=0x3028 pak=0x000000 ds=0x000000 status=80 pak_size=0

03 bd_ptr=0x303C pak=0x000000 ds=0x000000 status=80 pak_size=0

04 bd_ptr=0x3050 pak=0x000000 ds=0x000000 status=80 pak_size=0

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

0 residual bit errors

R-22#

Thanks.

Re: Modem for maintenance use (I'm down)

Hi .. mmm .. this is a kind of tricky procedure to follow ... it has three pieces to teh puzzle.

1.- configuring the logical part ( IP addresses, encapsulation ..etc) This is done from the physical interface in your case it should be serial0 ..so your config shoudl look something like this:

Under the serial0 interface

physical-layer async

ip unnumbered Ethernet0

encapsulation ppp

bandwidth 38

async mode interactive

peer default ip address pool dialup

no cdp enable

ppp authentication chap

2.- Configuring the physical part such as speed, flow control ..etc > this is done under the relevant TTY line number which represents your serial0 interface. You discover this using the show line command. In your case I believe it is line 2 but you can check this with your router's manual. So the speeed, flow control ..etc setting have to go under the line mode.

3.- Your modem needs to be recognised by the router. A router has a database known as modemcap. This database shows the modems the router knows about and it settings. You need to find your modem on this database or add it if it is not there. Do a show modemcap and see whether your modem is listed. If it is then use the command

autoconfigure type

It is a bit of a pain so .. just let me know if you get stack as I ahve a procedure from a CCNP book I have got ... If you need more assistance.

Once you have configured you should be able to connect to your router by dialing to phome number used by the modem.

I hope it helps ... please rate it if it does !!!

New Member

Re: Modem for maintenance use (I'm down)

Hi to all!

I recognize I don't have enough knowledge by kindly pointing out.

1.- Thanks for your advices. I will be helped by that!

2.- I had wanted to use wrong interface and wrong cable. And now I know I need a connector and a cable I have. The serial interface is not async interface, is it?

3.- Thanks I will do it later.

>It is a bit of a pain so .. just let me know if you >get stack as I ahve a procedure from a CCNP book I >have got ... If you need more assistance.

My networking skill is the secret of my nation.

So I can't disclose it! But I have that book.

I had jumped to hasty conclusions!

That's all! (`・ω・´)hahaha

Thanks for your kindly advices, Mr. fernand!

New Member

Re: Modem for maintenance use (I'm down)

I have one-third done! (`・ω・´)

R-22#sh line aux 0

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

I 1 AUX 38400/38400 - inout - - - 0 1 0/0 -

Line 1, Location: "Gyoutoku_Zousui_for_training", Type: ""

Length: 24 lines, Width: 80 columns

Baud rate (TX/RX) is 38400/38400, no parity, 1 stopbits, 8 databits

Status: No Exit Banner, Modem Detected, CTS Raised, Modem Signals Polled

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

Modem Callout, Modem RI is CD, Line usable as async interface

Modem Discovery

Modem state: Idle

Modem hardware state: CTS* noDSR DTR RTS, Modem Configured

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch

00:10:00 00:20:00 none not set

Idle Session Disconnect Warning

00:01:00

Login-sequence User Response

00:00:30

Autoselect Initial Wait

not set

Modem type is default.

Session limit is not set.

Time since activation: never

Editing is enabled.

History is enabled, history size is 10.

DNS resolution in show commands is enabled

Full user help is disabled

Allowed input transports are pad v120 telnet rlogin udptn.

Allowed output transports are pad v120 telnet rlogin.

Preferred transport is telnet.

No output characters are padded

No special data dispatching characters

R-22#

New Member

Re: Modem for maintenance use (I'm down)

Hello to all!

It's one step forward! I must build up RAS Server.

For my TLE is TLE Kit what I build up! (`・ω・´)

I don't know whether it works or not.

I need its test phase.

New Member

Re: Modem for maintenance use (I'm down)

R-22#start-chat Reno aux 0 1234567890

00:54:56: CHAT1: Matched chat script Reno to string Reno

00:54:56: CHAT1: Asserting DTR

00:54:56: TTY1: Set DTR to 1

00:54:56: CHAT1: Chat script Reno started

00:54:56: CHAT1: Sending string: ATZ

00:54:56: CHAT1: Expecting string: OK

00:54:57: CHAT1: Completed match for expect: OK

00:54:57: CHAT1: Sending string: ATDT \T<1234567890>

00:54:57: CHAT1: Expecting string: CONNECT

00:55:01: %LANCE-5-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

Local MobileIP: aging arp mobility cache entries

00:55:10: DHCPD: checking for expired leases.

New Member

Re: Modem for maintenance use (I'm down)

00:55:11: %LANCE-5-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

00:55:21: %LANCE-5-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

00:55:27: CHAT1: Timeout expecting: CONNECT

00:55:27: CHAT1: Chat script Reno finished, status = Connection timed out; remot

e host not responding

00:55:27: As1 AAA/DISC: 9/"NAS Error"

00:55:27: As1 AAA/DISC/EXT: 1002/"Unknown"

00:55:27: As1 AAA/DISC: 9/"NAS Error"

00:55:27: As1 AAA/DISC/EXT: 1002/"Unknown"

00:55:27: TTY1: Line reset by "Exec"

00:55:27: TTY1: Modem: IDLE->HANGUP

00:55:27: TTY1: destroy timer type 0

00:55:27: TTY1: destroy timer type 1

00:55:27: TTY1: destroy timer type 3

00:55:27: TTY1: destroy timer type 4

00:55:27: TTY1: destroy timer type 2

00:55:27: As1 AAA/DISC: 2/"Lost Carrier"

00:55:27: As1 AAA/DISC/EXT: 1011/"Lost Carrier"

00:55:27: As1 AAA/DISC: 2/"Lost Carrier"

00:55:27: As1 AAA/DISC/EXT: 1011/"Lost Carrier"

00:55:27: TTY1: dropping DTR, hanging up

00:55:27: TTY1: Set DTR to 0

00:55:27: tty1: Modem: HANGUP->IDLE

00:55:28: TTY1: restoring DTR

00:55:28: TTY1: Set DTR to 1

00:55:29: TTY1: autoconfigure probe started

00:55:29: TTY1: Modem command: --AT&F&C1&D2S0=1H0--

00:55:30: TTY1: Modem configuration succeeded

00:55:30: TTY1: Detected modem speed 38400

00:55:30: TTY1: Done with modem configuration

00:55:31: %LANCE-5-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

00:55:41: %LANCE-5-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

R-22#u all

All possible debugging has been turned off

New Member

Re: Modem for maintenance use (I'm down)

I have done. It's an easy task. (`・ω・´)

R-22#show stac

Minimum process stacks:

Free/Size Name

1960/4000 Init

3400/4000 RADIUS INITCONFIG

980/2000 Modem Autoconfigure

4668/5000 DHCP Client

5604/6000 Router Init

Interrupt level stacks:

Level Called Unused/Size Name

3 0 3000/3000 Serial interface state change interrupt

4 694 2636/3000 Network interfaces

5 95315 2884/3000 Console Uart

New Member

Re: Modem for maintenance use (I'm down)

R-22#ping 192.168.39.2^@

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.39.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

R-22#exit

NO CARRIER

OK

+MCR: V34

+MRR: 31200

+ER: LAPM

+DR: V42B

CONNECT 31200

User Access Verification

Username: xxx

Password:

R-22>

R-22>en

Password:

R-22#sh stac

Minimum process stacks:

Free/Size Name

1960/4000 Init

3400/4000 RADIUS INITCONFIG

980/2000 Modem Autoconfigure

4668/5000 DHCP Client

5604/6000 Router Init

1952/4000 Exec

Interrupt level stacks:

Level Called Unused/Size Name

3 0 3000/3000 Serial interface state change interrupt

4 847 2636/3000 Network interfaces

5 100035 2884/3000 Console Uart

R-22#

R-22#exit

NO CARRIER

163
Views
0
Helpful
9
Replies