Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

modem problem Requested circuit/channel not available(0x2C)

Hi,

I'm commissioning a new AS5350 router connected to a E1 ISDN line to accept modem calls, but I keep getting the following error when I dial the ISDN line from a modem:

AS5350#deb isdn eve
debug isdn event is             ON.
AS5350#
*Jul  6 21:19:47.505: ISDN Se3/0:15 EVENT: process_rxstate: ces/callid 1/0x39 calltype 2 CALL_INCOMING
*Jul  6 21:19:47.505: ISDN Se3/0:15 EVENT: call_incoming: call_id 0x0039, Guid = FD710244803A
*Jul  6 21:19:47.505: ISDN Se3/0:15 EVENT: UserIdle: callid 0x39 received ACCEPT_CALL (0x13)
*Jul  6 21:19:47.505: ISDN Se3/0:15 **ERROR**: accept_incoming_csm_call: modem problem Requested circuit/channel not available(0x2C): b channel 0, call id 0x39
*Jul  6 21:19:47.693: ISDN Se3/0:15 EVENT: process_rxstate: ces/callid 1/0x39 calltype 2 CALL_CLEARED
AS5350#

config info below:

AS5350#sh ver
Cisco IOS Software, 5350 Software (C5350-IS-M), Version 12.4(9)T7, RELEASE SOFTWARE (fc3)
Technical Support:
http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 10-Jan-08 18:52 by prod_rel_team

ROM: System Bootstrap, Version 12.4(22r)T, RELEASE SOFTWARE (fc1)

AS5350 uptime is 6 weeks, 43 minutes
System returned to ROM by Reload Command at 20:15:55 UTC Thu May 25 2000
System image file is "flash:c5350-is-mz.124-9.T7.bin"

Cisco AS5350XM (BCM) processor (revision 0x22) with 393215K/131072K bytes of memory.
Processor board ID JAE1328E1WW
SB-1 CPU at 750MHz, Implementation 1025, Rev 0.3, 256KB L2 Cache
Last reset from IOS reload
Manufacture Cookie Info:
EEPROM Version 0x4, Board ID 0x4C3,
Board Hardware Version 2.7, Item Number 800-6571779-03,
Board Revision B0, Serial Number JAE1328E1WW.
Processor 0x0, MAC Address 0022.9158.1dfc
2 Gigabit Ethernet interfaces
37 Serial interfaces
2 Channelized E1/PRI ports
512K bytes of NVRAM.
126000K bytes of ATA External CompactFlash (Read/Write)

Configuration register is 0x2102

AS5350#sh inv
NAME: "AS5350XM chassis", DESCR: "AS5350XM chassis"
PID: AS535XM-AC-PWR    , VID: V03, SN: JAE1328E1WW

NAME: "AS5X-FC_1", DESCR: "AS5000 Feature Card with Six AS5X PVDM DSP Module Slots"
PID: AS5X-FC           , VID: V01, SN: JAE1326D8H9

NAME: "PVDMII DSP SIMM with four DSPs 1/0", DESCR: "PVDMII DSP SIMM with four DSPs"
PID: AS5X-PVDM2-64
^]D  , VID: V01, SN: FOC13342044

NAME: "PVDMII DSP SIMM with four DSPs 1/1", DESCR: "PVDMII DSP SIMM with four DSPs"
PID: AS5X-PVDM2-64
^]D  , VID: V01, SN: FOC1334205W

NAME: "PVDMII DSP SIMM with four DSPs 1/2", DESCR: "PVDMII DSP SIMM with four DSPs"
PID: AS5X-PVDM2-64
^]D  , VID: V01, SN: FOC13342045

NAME: "E1_3", DESCR: "E1 2 PRI DFC, HwVer#: 2.7"
PID:                   , VID:    , SN: JAE1336I67B


AS5350#sh run
Building configuration...

Current configuration : 3577 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AS5350
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable secret <snip>
!
!
!
resource-pool disable
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
isdn switch-type primary-net5
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 3/0
pri-group timeslots 1-31
description ISDN30
!
controller E1 3/1
shutdown
description NOT IN USE
!
!
!
interface Loopback1
no ip address
!
interface GigabitEthernet0/0
description Link to Internal production network
ip address aa.bb.58.245 255.255.255.248
ip access-group 107 in
duplex full
speed 1000
negotiation auto
!
interface GigabitEthernet0/1
description Link to management network
ip address aa.bb.58.100 255.255.255.224
ip access-group 107 in
duplex full
speed 100
negotiation auto
!
interface Serial0/0
no ip address
clock rate 2000000
no fair-queue
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial3/0:15
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
no fair-queue
no cdp enable
!
interface Dialer1
ip unnumbered Loopback1
encapsulation ppp
no ip mroute-cache
dialer in-band
dialer idle-timeout 3600
dialer-group 1
peer default ip address pool dialin-pool
no fair-queue
no cdp enable
ppp authentication chap pap
!
interface Group-Async0
physical-layer async
no ip address
encapsulation slip
!
interface Group-Async1
physical-layer async
ip unnumbered Loopback1
encapsulation ppp
no ip route-cache cef
async mode interactive
peer default ip address pool dialin-pool
ppp max-bad-auth 3
ppp authentication pap
!
!
ip route 0.0.0.0 0.0.0.0 aa.bb.58.97
no ip http server
!
!
access-list 107 deny   tcp any any eq 1720
access-list 107 permit ip any any
!
!
!
control-plane
!
!
!
voice-port 3/0:D
!
!
!
!
sip-ua
no transport udp
no transport tcp
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
password <snip>
login
line aux 0
line vty 0 4
password <snip>
login
!
scheduler allocate 10000 400
end


AS5350#sh isdn status
Global ISDN Switchtype = primary-net5
ISDN Serial3/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0
AS5350#sh isdn service
PRI Channel Statistics:
ISDN Se3/0:15, Channel [1-31]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Any ideas where I'm going wrong?

Thanks in advance.

Bob.

Everyone's tags (3)
2 REPLIES
New Member

Re: modem problem Requested circuit/channel not available(0x2C)

Hi

I have same problem with new 5350XM

My scheme looks like this:

PSTN<--E1-->7204VXR<--E1-->IP-mux<---Ethernet--->IP-mux<--E1-->5350XM

PRI status is ok from both sides,but every time I try to call I recieving this error:

From 5350XM:

Jan 14 10:54:03.406: ISDN Se1/0:15 **ERROR**: accept_incoming_csm_call: modem problem Requested circuit/channel not available(0x2C): b channel 30, call id 0xA

From 7204:

Jan 14 10:54:03.416: ISDN Se1/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0xF7C3
        Channel ID i = 0xA9839F
                Exclusive, Channel 31
Jan 14 10:54:03.416: ISDN Se1/0:15 Q931: RX <- DISCONNECT pd = 8  callref = 0xF7C3
        Cause i = 0x82AC - Requested circuit/channel not available


I need some help with this problem too.

Thanks.

--------------5350XM:-----------------

5350XM#sh isdn status serial3/1:15
Global ISDN Switchtype = primary-qsig
ISDN Serial3/1:15 interface
    ******* Network side configuration *******
    dsl 2, interface ISDN Switchtype = primary-qsig
     **** Master side configuration ****
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 2 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0
5350XM#

5350XM#sh isdn service serial3/1:15
PRI Channel Statistics:
ISDN Se3/1:15, Channel [1-31]
  Configured Isdn Interface (dsl) 2
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

--------------7204:-----------------

7204#sh isdn status serial1/0:15
Global ISDN Switchtype = primary-qsig
ISDN Serial1/0:15 interface
    dsl 0, interface ISDN Switchtype = primary-qsig
     **** Slave side configuration ****
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 22
    Total Allocated ISDN CCBs = 10

7204#sh isdn service serial1/0:15
PRI Channel Statistics:
ISDN Se1/0:15, Channel [1-31]
  Configured Isdn Interface (dsl) 0
   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)
    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

------------------------------------------

System image file is "flash:c5350-is-mz.124-9.T7.bin"

Cisco AS5350XM (BCM) processor (revision 0x22) with 393215K/131072K bytes of memory.
Processor board ID JAE1342LA17
SB-1 CPU at 750MHz, Implementation 1025, Rev 0.3, 256KB L2 Cache
Last reset from power-on
Manufacture Cookie Info:
EEPROM Version 0x4, Board ID 0x4C3,
Board Hardware Version 2.7, Item Number 800-6571779-03,
Board Revision B0, Serial Number JAE1342LA17.
Processor 0x0, MAC Address 0022.9158.251e
2 Gigabit Ethernet interfaces
134 Serial interfaces
4 Channelized E1/PRI ports
512K bytes of NVRAM.
126000K bytes of ATA External CompactFlash (Read/Write)

5350XM#sh run

tdm clock priority 3 freerun
!
ip cef
!
isdn switch-type primary-qsig
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
modem passthrough nse codec g711ulaw
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
controller E1 2/0
shutdown
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 2/1
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/0
shutdown
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
!        
!
interface Serial2/0:15
no ip address
encapsulation hdlc
shutdown
isdn switch-type primary-qsig
no cdp enable
!
interface Serial2/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn protocol-emulate network
isdn incoming-voice modem
isdn T310 120000
no cdp enable
!
interface Serial3/0:15
no ip address
encapsulation hdlc
shutdown
isdn switch-type primary-qsig
no cdp enable
!
interface Serial3/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn protocol-emulate network
isdn incoming-voice modem
isdn T310 120000
no cdp enable
!
!
voice-port 2/0:D
!
voice-port 2/1:D
bearer-cap Speech
!
voice-port 3/0:D
!
voice-port 3/1:D
bearer-cap Speech
!
!
!
dial-peer voice 6 pots
preference 1
destination-pattern 6T
port 2/1:D
prefix 6
!
dial-peer voice 179 voip
description Asterisk
destination-pattern 179..
voice-class codec 1
session protocol sipv2
session target ipv4:192.0.0.2
dtmf-relay rtp-nte
no vad
!
dial-peer voice 12 pots
preference 1
destination-pattern 12...
progress_ind setup enable 3
progress_ind alert enable 8
direct-inward-dial
port 3/1:D
prefix 12
!
!

5350XM#

Hall of Fame Super Gold

Re: modem problem Requested circuit/channel not available(0x2C)

You do not have modem cards in the router.

4407
Views
0
Helpful
2
Replies
CreatePlease to create content