Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Multiple ISDN dialer stops routing

Hi,

I have a 1721 with the BRI WICs.

The router is used for remote control for a series (20 different) sites, which callback for security reason.

It happens that after a while (two hours of operation) when I ping a site, the router starts dialing, but routing never occours and, after another piece of time, if I ping the router does not dial, even if debugging shows interesting traffic.

This is a sample of the configuration:

hostname myhost

username Site1 password Site1

username Site2 password Site2

....

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

!

!

no ip domain lookup

!

no ip cef

ip audit po max-events 100

no ftp-server write-enable

!

isdn switch-type basic-net3

!

!

!

!

!

!

interface BRI0

bandwidth 128

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp multilink

!

interface BRI1

bandwidth 128

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp multilink

!

interface FastEthernet0

ip address 10.0.0.1 255.255.255.0

speed 100

full-duplex

no cdp enable

!

interface Dialer1

bandwidth 128

ip address 172.16.1.253 255.255.255.252

encapsulation ppp

dialer pool 1

dialer remote-name Site1

dialer idle-timeout 30

dialer string 0XXXXXXX

dialer caller XXXXXXX

dialer load-threshold 1 either

dialer-group 1

no cdp enable

ppp multilink

!

other dialer are similar, then

ip classless

ip route 192.168.1.0 255.255.255.0 Dialer1

access-list 100 deny 53 any any

access-list 100 deny 55 any any

access-list 100 deny 77 any any

access-list 100 deny pim any any

access-list 100 deny udp any eq netbios-dgm any

access-list 100 deny udp any eq netbios-ns any

access-list 100 deny udp any eq netbios-ss any

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100

What's wrong with this???

Help please!

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Multiple ISDN dialer stops routing

Hello,

can you try and take all the multilink commands out of your configuration ? Assuming that your remote sites have only a single BRI connection, that might cause problems when 4 B-channels are bundled at your main site.

Regarding the dialer caller, that should be OK, provided your remote sites dial back to the originating number. If possible, can you post the configuration of a remote site router as well ?

Regards,

GNT

4 REPLIES

Re: Multiple ISDN dialer stops routing

Hello,

is this the full configuration of the router ? You have only 1 destination, also, you are saying that the sites have callback configured, but your router is not configured for accepting or requesting callback requests.

In addition, you have multilink configured so that all lines come up immediately, is that what you need/want ?

Regards,

GNT

New Member

Re: Multiple ISDN dialer stops routing

No, it's not the full configuration. After dialer1 I have written "other dialer are similar, then ", that means that there are other dialer (25), that are similar, except for IP's, phone numbers and remote names.

Regarding callback, what I need is to call a certain site, and be called back, but not the reverse, i.e.: I don't want the remote site to call me and be called back.

Therefore I have put a dialer caller XXXXXX callback only in the remote router, not in the one in central site, to whom this configuration abridgment belongs.

Isn't this correct?

Ciao

Re: Multiple ISDN dialer stops routing

Hello,

can you try and take all the multilink commands out of your configuration ? Assuming that your remote sites have only a single BRI connection, that might cause problems when 4 B-channels are bundled at your main site.

Regarding the dialer caller, that should be OK, provided your remote sites dial back to the originating number. If possible, can you post the configuration of a remote site router as well ?

Regards,

GNT

New Member

Re: Multiple ISDN dialer stops routing

I'll try to remove the multilink's and I'll tell what will happen. Anyway, shouldn't bandwidth 128 command allow one remote site to connect to main site using max 2 B-channels?

This is the dialer on the remote site that handles the connection with the main site.

interface Dialer99

ip address

encapsulation ppp

dialer pool 1

dialer remote-name myremote

dialer idle-timeout 30

dialer string 0XXXXXXXXX

dialer string 0YYYYYYYYY

dialer caller XXXXXXXXX callback

dialer caller YYYYYYYYY callback

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

The dialer string 0YYYYYYYYY means that the dialer string has a leading zero, as per italian numbering plan, while the called id has not. This is the reason why dialer string has a leading zero and dialer caller doesn't.

Ciao

122
Views
0
Helpful
4
Replies
CreatePlease to create content