Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Multiple vpdn-groups with vrf

Hi all,

I wanna to install an LNS for PPTP tunnel ending,I created "vpdn-group 1" and "vpdn-group 2", which connect to "vpdn-group 1" put into vrf "test1" ,

connect to "vpdn-group 2" put into vrf "test2". when i use windows xp client connect ,i saw all sessions terminate within the group "vpdn-group 1",

the 2nd group is not used at all. Then i remove "vpdn-group 1",saw "vpdn-group 2" was worked well.Anybody can tell me why?Thx.

-----------------------------------------

ip cef

ip vrf test1

rd 1:1

route-target export 1:1

route-target import 1:1

!

ip vrf test2

rd 2:2

route-target export 2:2

route-target import 2:2

!

ip dhcp pool test1

vrf test1

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 202.96.134.133 202.96.128.6

!

ip dhcp pool test2

vrf test2

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

dns-server 202.96.134.133 202.96.128.6

!

username vpn1 password 0 vpn1

username vpn2 password 0 vpn2

aaa new-model

aaa authentication ppp default local

aaa authorization network default local

!

interface Loopback11

ip address 202.96.1.1 255.255.255.255

!

interface Loopback12

ip address 202.96.1.2 255.255.255.255

!

interface Loopback101

ip vrf forwarding test1

ip address 10.0.0.1 255.255.255.0

!

interface Loopback102

ip vrf forwarding test2

ip address 10.0.0.1 255.255.255.0

!

interface Virtual-Template1

ip vrf forwarding test1

ip unnumbered Loopback101

peer default ip address dhcp-pool test1

ppp authentication chap ms-chap

!

interface Virtual-Template2

ip vrf forwarding test2

ip unnumbered Loopback102

peer default ip address dhcp-pool test2

ppp authentication chap ms-chap

!

vpdn enable

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

vpn vrf test1

source-ip 202.96.1.1

!

vpdn-group 2

accept-dialin

protocol pptp

virtual-template 2

vpn vrf test2

source-ip 202.96.1.2

!

1 REPLY
Silver

Re: Multiple vpdn-groups with vrf

This problem may cause due to multiple tunnels from same client.

http://www.cisco.com/en/US/docs/ios/12_2/12_2b/12_2b4/feature/guide/12b_vrf.html#wp1039321

809
Views
0
Helpful
1
Replies
CreatePlease to create content