cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
360
Views
0
Helpful
1
Replies

NAT with DSL and CableModem

william.caban
Level 5
Level 5

Scenario:

Having DSL and Cable Modem to the same router. DSL will only be activated if the Cable goes down.

Question:

Is it possible to configure NAT such that it detects the change of IP from the Cable to the DSL and dynamically reset the current NAT and start doing the overloading with the new IP from the DSL?

--William

1 Accepted Solution

Accepted Solutions

Hello William,

have a look at the sample configuration below, which I think might apply to your situation (you might have to change the interfaces, if you are using PPPoE, but you get the idea):

ip cef

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer1

description CableModem Connection

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description DSL_CONNECTION

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

!

route-map ISP1_Connection_1 permit 10

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match interface Dialer2

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 200

!

dialer-list 1 protocol ip permit

HTH,

GP

View solution in original post

1 Reply 1

Hello William,

have a look at the sample configuration below, which I think might apply to your situation (you might have to change the interfaces, if you are using PPPoE, but you get the idea):

ip cef

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

!

interface Dialer1

description CableModem Connection

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

interface Dialer2

description DSL_CONNECTION

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip nat inside source route-map ISP1_Connection_1 interface Dialer1 overload

ip nat inside source route-map ISP1_Connection_2 interface Dialer2 overload

!

route-map ISP1_Connection_1 permit 10

match interface Dialer1

!

route-map ISP1_Connection_2 permit 10

match interface Dialer2

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2 200

!

dialer-list 1 protocol ip permit

HTH,

GP